summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-03-26 16:35:07 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-26 21:35:44 +0100
commit99b115e081167013d51cc0e5b415a1c66175128a (patch)
tree5615eba60ca16d2fa37468e5cbac7157b773a2fa
parentd41722e4f4869d3a0b70ec588db391f3e4f3fdce (diff)
downloadbuildroot-99b115e081167013d51cc0e5b415a1c66175128a.tar.gz
buildroot-99b115e081167013d51cc0e5b415a1c66175128a.zip
cairo: enable opengl for cairo-gl
If OpenGL is enabled then enable cairo-gl. However if GLESv2 is also present we must choose which implementation to use. Since normally OpenGL is more featured, has more dependencies and wouldn't be present "by accident" it seems like the logical choice to win over it. This feature is useful for webkitgtk's accelerated 2d canvas. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/cairo/cairo.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/cairo/cairo.mk b/package/cairo/cairo.mk
index ab0c2e8338..b79899565b 100644
--- a/package/cairo/cairo.mk
+++ b/package/cairo/cairo.mk
@@ -79,11 +79,17 @@ else
CAIRO_CONF_OPTS += --disable-gobject
endif
+# Can use GL or GLESv2 but not both
+ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
+CAIRO_CONF_OPTS += --enable-gl --disable-glesv2
+CAIRO_DEPENDENCIES += libgl
+else
ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
-CAIRO_CONF_OPTS += --enable-glesv2
+CAIRO_CONF_OPTS += --disable-gl --enable-glesv2
CAIRO_DEPENDENCIES += libgles
else
-CAIRO_CONF_OPTS += --disable-glesv2
+CAIRO_CONF_OPTS += --disable-gl --disable-glesv2
+endif
endif
ifeq ($(BR2_PACKAGE_HAS_LIBOPENVG),y)
OpenPOWER on IntegriCloud