summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2017-07-29 22:32:20 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-29 22:42:51 +0200
commit8d6371f51265ac6d460e7b1cfc987c9fd2f0785d (patch)
treeb17722dafc2a3147db58f5cb2a23f8f3cc9bcf92
parent63eeb9a383991b9ac92b524b63ac87f7b4657699 (diff)
downloadbuildroot-8d6371f51265ac6d460e7b1cfc987c9fd2f0785d.tar.gz
buildroot-8d6371f51265ac6d460e7b1cfc987c9fd2f0785d.zip
package/cc-tool: link with libatomic when needed
Detecting the boost program_options library is broken: checking for the Boost program_options library... no configure: error: cannot find the flags to link with Boost program_options config.log shows the reason, libatomic is missing: conftest.o: In function `boost::detail::sp_counted_base::release()': conftest.cpp:(.text._ZN5boost6detail15sp_counted_base7releaseEv[_ZN5boost6detail15sp_counted_base7releaseEv]+0xc): undefined reference to `__atomic_fetch_sub_4' conftest.cpp:(.text._ZN5boost6detail15sp_counted_base7releaseEv[_ZN5boost6detail15sp_counted_base7releaseEv]+0x38): undefined reference to `__atomic_fetch_sub_4' /home/buildroot/br4/output/host/sparc-buildroot-linux-uclibc/sysroot/usr/lib/libboost_program_options.so: undefined reference to `__atomic_fetch_add_4' Please note that using LIBS=-latomic is not enough, although it fixes the configure check the bug reoccurs when linking cc-tool: CXXLD cc-tool src/application/cc_flasher.o: In function `boost::detail::sp_counted_base::weak_release()': cc_flasher.cpp:(.text._ZN5boost6detail15sp_counted_base12weak_releaseEv[_ZN5boost6detail15sp_counted_base12weak_releaseEv]+0xc): undefined reference to `__atomic_fetch_sub_4' We need to add -latomic to CXXFLAGS to both fix configure and linking. Fixes http://autobuild.buildroot.net/results/596/596f97364bb2c7598b0646da8160939356f0d2c6/ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/cc-tool/cc-tool.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/cc-tool/cc-tool.mk b/package/cc-tool/cc-tool.mk
index b9209ced3d..37ac57e497 100644
--- a/package/cc-tool/cc-tool.mk
+++ b/package/cc-tool/cc-tool.mk
@@ -23,4 +23,8 @@ ifeq ($(BR2_STATIC_LIBS),y)
CC_TOOL_CONF_ENV += LIBS="-lpthread"
endif
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+CC_TOOL_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -latomic"
+endif
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud