summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2015-04-30 17:12:18 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-01 22:57:18 +0200
commit87523028fa4c559ca38f30858b775904273c483a (patch)
treebb21fca0b7092077e902d1ceb9a11d5af3e3ecec
parentc9ecdd2b96ece42468e1dbaa26dbeda152aabd90 (diff)
downloadbuildroot-87523028fa4c559ca38f30858b775904273c483a.tar.gz
buildroot-87523028fa4c559ca38f30858b775904273c483a.zip
gpu-viv-bin-mx6q: make fb/x11 choice explicit
This approach is less error-prone during development. Tested-by: Gary Bisson <gary.bisson@boundarydevices.com> Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com> Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/freescale-imx/gpu-viv-bin-mx6q/Config.in23
-rw-r--r--package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk2
2 files changed, 22 insertions, 3 deletions
diff --git a/package/freescale-imx/gpu-viv-bin-mx6q/Config.in b/package/freescale-imx/gpu-viv-bin-mx6q/Config.in
index c59535e0e3..c770346c71 100644
--- a/package/freescale-imx/gpu-viv-bin-mx6q/Config.in
+++ b/package/freescale-imx/gpu-viv-bin-mx6q/Config.in
@@ -7,8 +7,6 @@ config BR2_PACKAGE_GPU_VIV_BIN_MX6Q
select BR2_PACKAGE_HAS_LIBEGL
select BR2_PACKAGE_HAS_LIBGLES
select BR2_PACKAGE_HAS_LIBOPENVG
- select BR2_PACKAGE_XLIB_LIBXDAMAGE if BR2_PACKAGE_XORG7
- select BR2_PACKAGE_XLIB_LIBXEXT if BR2_PACKAGE_XORG7
depends on BR2_arm # Only relevant for i.MX6
# Library binaries are linked against libc.so.6
depends on BR2_TOOLCHAIN_USES_GLIBC
@@ -25,6 +23,27 @@ config BR2_PACKAGE_GPU_VIV_BIN_MX6Q
if BR2_PACKAGE_GPU_VIV_BIN_MX6Q
+choice
+ prompt "Output option"
+ help
+ There are two versions of this library: one for
+ direct framebuffer access, one for X11 rendering.
+ Choose here which version to install.
+
+config BR2_PACKAGE_GPU_VIV_BIN_MX6Q_OUTPUT_X11
+ bool "X11"
+ depends on BR2_PACKAGE_XORG7
+ select BR2_PACKAGE_XLIB_LIBXDAMAGE
+ select BR2_PACKAGE_XLIB_LIBXEXT
+
+comment "X11 backend needs Xorg package"
+ depends on !BR2_PACKAGE_XORG7
+
+config BR2_PACKAGE_GPU_VIV_BIN_MX6Q_OUTPUT_FB
+ bool "Framebuffer"
+
+endchoice
+
config BR2_PACKAGE_PROVIDES_LIBEGL
default "gpu-viv-bin-mx6q"
diff --git a/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk b/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk
index bad1658b94..f96087b411 100644
--- a/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk
+++ b/package/freescale-imx/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.mk
@@ -21,7 +21,7 @@ GPU_VIV_BIN_MX6Q_REDISTRIBUTE = NO
GPU_VIV_BIN_MX6Q_PROVIDES = libegl libgles libopenvg
# DirectFB is not supported (wrong version)
-ifeq ($(BR2_PACKAGE_XORG7),y)
+ifeq ($(BR2_PACKAGE_GPU_VIV_BIN_MX6Q_OUTPUT_X11),y)
GPU_VIV_BIN_MX6Q_DEPENDENCIES = xlib_libXdamage xlib_libXext
GPU_VIV_BIN_MX6Q_LIB_TARGET = x11
else
OpenPOWER on IntegriCloud