summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openadk.org>2018-02-01 21:09:04 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-02-06 14:05:44 +0100
commit873040371b1436d480fb9153427504ce9e3d78cf (patch)
tree6556227b6c1300a2973f528344c2348e8b8b244e
parentc032e6825ad96e6d4b69cecde2402c02a2a356b5 (diff)
downloadbuildroot-873040371b1436d480fb9153427504ce9e3d78cf.tar.gz
buildroot-873040371b1436d480fb9153427504ce9e3d78cf.zip
autofs: allow to use libtirpc
uClibc-ng removed internal RPC implementation as it is ipv4 only and can not be used for most important RPC software rpcbind and nfs-utils. musl does not implement RPC and GNU C library deprecated the internal implementation a while ago. It is still possible to use the C library implementation. Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> [Thomas: change to use libtirpc when available, not just when the toolchain does not have RPC support.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-rw-r--r--package/autofs/Config.in7
-rw-r--r--package/autofs/autofs.mk9
2 files changed, 11 insertions, 5 deletions
diff --git a/package/autofs/Config.in b/package/autofs/Config.in
index 8e08357a4e..efb0ec28ee 100644
--- a/package/autofs/Config.in
+++ b/package/autofs/Config.in
@@ -2,8 +2,8 @@ config BR2_PACKAGE_AUTOFS
bool "autofs"
depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
depends on BR2_USE_MMU
- depends on BR2_TOOLCHAIN_HAS_NATIVE_RPC
depends on !BR2_STATIC_LIBS # dlfcn
+ select BR2_PACKAGE_LIBTIRPC if !BR2_TOOLCHAIN_HAS_NATIVE_RPC
help
Autofs controls the operation of the automount daemons. The
automount daemons automatically mount filesystems when they
@@ -15,7 +15,6 @@ config BR2_PACKAGE_AUTOFS
http://www.linuxfromscratch.org/blfs/view/svn/general/autofs.html
-comment "autofs needs a toolchain w/ NPTL, RPC, dynamic library"
+comment "autofs needs a toolchain w/ NPTL and dynamic library"
depends on BR2_USE_MMU
- depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS || \
- !BR2_TOOLCHAIN_HAS_NATIVE_RPC
+ depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS
diff --git a/package/autofs/autofs.mk b/package/autofs/autofs.mk
index 90cc38de55..87a218441e 100644
--- a/package/autofs/autofs.mk
+++ b/package/autofs/autofs.mk
@@ -9,7 +9,7 @@ AUTOFS_SOURCE = autofs-$(AUTOFS_VERSION).tar.xz
AUTOFS_SITE = $(BR2_KERNEL_MIRROR)/linux/daemons/autofs/v5
AUTOFS_LICENSE = GPL-2.0+
AUTOFS_LICENSE_FILES = COPYING COPYRIGHT
-AUTOFS_DEPENDENCIES = host-flex host-bison
+AUTOFS_DEPENDENCIES = host-flex host-bison host-pkgconf
# autofs looks on the build machine for the path of modprobe, so tell
# it explicitly where it will be located on the target.
@@ -31,4 +31,11 @@ AUTOFS_CONF_OPTS = \
AUTOFS_MAKE_ENV = DONTSTRIP=1
+ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
+AUTOFS_CONF_OPTS += --with-libtirpc
+AUTOFS_DEPENDENCIES += libtirpc
+else
+AUTOFS_CONF_OPTS += --without-libtirpc
+endif
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud