summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-09-10 08:51:44 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-11 15:35:54 +0200
commit6a35b6e3a56bbc5eed8eab9896be431bdf81e5e1 (patch)
tree16b98446d446f20dbf53369b946769bed551b462
parent57d0a568da4dd3e49c06af79a24ecaafaf14cbe4 (diff)
downloadbuildroot-6a35b6e3a56bbc5eed8eab9896be431bdf81e5e1.tar.gz
buildroot-6a35b6e3a56bbc5eed8eab9896be431bdf81e5e1.zip
linux-firmware: add bluetooth firmware for intel chips
It probably makes no sense to try split them up by model since there aren't that big. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/linux-firmware/Config.in10
-rw-r--r--package/linux-firmware/linux-firmware.mk6
2 files changed, 16 insertions, 0 deletions
diff --git a/package/linux-firmware/Config.in b/package/linux-firmware/Config.in
index f56f31df67..79af71eeb1 100644
--- a/package/linux-firmware/Config.in
+++ b/package/linux-firmware/Config.in
@@ -26,6 +26,16 @@ config BR2_PACKAGE_LINUX_FIRMWARE_RADEON
endmenu # Video
+menu "Bluetooth firmware"
+
+config BR2_PACKAGE_LINUX_FIRMWARE_IBT
+ bool "Intel Wireless Bluetooth"
+ help
+ Firmware files for Intel 3160/7260/7265/8260/8265 Wireless
+ bluetooth support.
+
+endmenu # Bluetooth
+
menu "WiFi firmware"
config BR2_PACKAGE_LINUX_FIRMWARE_ATHEROS_6002
diff --git a/package/linux-firmware/linux-firmware.mk b/package/linux-firmware/linux-firmware.mk
index 140184870b..5c80c1e571 100644
--- a/package/linux-firmware/linux-firmware.mk
+++ b/package/linux-firmware/linux-firmware.mk
@@ -19,6 +19,12 @@ LINUX_FIRMWARE_DIRS += radeon
LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENSE.radeon
endif
+# Intel Wireless Bluetooth
+ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_IBT),y)
+LINUX_FIRMWARE_FILES += intel/ibt-*
+LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.ibt_firmware
+endif
+
# rt2501/rt61
ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_RALINK_RT61),y)
LINUX_FIRMWARE_FILES += rt2561.bin rt2561s.bin rt2661.bin
OpenPOWER on IntegriCloud