summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2018-03-31 09:20:20 +0200
committerPeter Korsgaard <peter@korsgaard.com>2018-03-31 09:26:19 +0200
commit5966e2dc54dfb19c5fde3a09d72f3abc6125c202 (patch)
treeb64d946aaee28b7d0558ffd3b3b485f59e2268ed
parent9feb6d982d7a5e3b61cc19ad9733dd3e737bf6a0 (diff)
downloadbuildroot-5966e2dc54dfb19c5fde3a09d72f3abc6125c202.tar.gz
buildroot-5966e2dc54dfb19c5fde3a09d72f3abc6125c202.zip
package/openocd: fix fallout after no-C++ fixups
Commit 4cd1ab158 (core: alternate solution to disable C++) made use of a non-existent 'no' binary when C++ is not available in the toolchain. However, some packages, like jimtcl as bundled in opeocd, really want to find the binary that $CXX contains. Revert openocd to use 'false' instead of 'no'. Fixes: http://autobuild.buildroot.org/results/cbd/cbd5ab97fb0659968ff628461130627cf1745955/ Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/openocd/openocd.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/openocd/openocd.mk b/package/openocd/openocd.mk
index 9d2576ceeb..548d8b81a0 100644
--- a/package/openocd/openocd.mk
+++ b/package/openocd/openocd.mk
@@ -11,7 +11,12 @@ OPENOCD_LICENSE = GPL-2.0+
OPENOCD_LICENSE_FILES = COPYING
# 0002-configure-enable-build-on-uclinux.patch patches configure.ac
OPENOCD_AUTORECONF = YES
-OPENOCD_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
+
+# The bundled jimtcl really wants to find a existing $CXX, so feed it
+# false when we do not have one.
+OPENOCD_CONF_ENV = \
+ $(if $(BR2_INSTALL_LIBSTDCPP),,CXX=false) \
+ CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
OPENOCD_CONF_OPTS = \
--oldincludedir=$(STAGING_DIR)/usr/include \
OpenPOWER on IntegriCloud