summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2017-05-29 22:13:29 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-05-29 22:20:07 +0200
commit557f8d649d9a959e810a3c92774020a434d567a8 (patch)
tree533bd6ea25e01701f4e98f0a7ad3261037b6bc62
parent80ebba2b5ad8017440b3ad84dd44261f7865dfc4 (diff)
downloadbuildroot-557f8d649d9a959e810a3c92774020a434d567a8.tar.gz
buildroot-557f8d649d9a959e810a3c92774020a434d567a8.zip
package/google-breakpad: use PRE_CONFIGURE hooks to copy linux_syscall_support.h
As reported by Bernd [1], using POST_EXTRACT to copy linux_syscall_support.h break the legal-info target when google-breakpad package is selected: /usr/bin/install: cannot stat '/home/bernd/buildroot/buildroot/output/ost/usr/i586-buildroot-linux-uclibc/sysroot/usr/include/linux_syscall_support.h': No such file or directory This is because linux_syscall_support.h is installed by a dependency of google-breakpad, and dependencies are only guaranteed to be available for the configure step of a package. To fix this, we use a PRE_CONFIGURE hook instead of POST_EXTRACT hook. [1] http://lists.busybox.net/pipermail/buildroot/2017-May/192844.html Reported-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/google-breakpad/google-breakpad.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/google-breakpad/google-breakpad.mk b/package/google-breakpad/google-breakpad.mk
index 191ee5bec2..3501f45b12 100644
--- a/package/google-breakpad/google-breakpad.mk
+++ b/package/google-breakpad/google-breakpad.mk
@@ -23,14 +23,14 @@ define HOST_GOOGLE_BREAKPAD_LSS
$(HOST_DIR)/usr/include/linux_syscall_support.h \
$(@D)/src/third_party/lss/linux_syscall_support.h
endef
-HOST_GOOGLE_BREAKPAD_POST_EXTRACT_HOOKS += HOST_GOOGLE_BREAKPAD_LSS
+HOST_GOOGLE_BREAKPAD_PRE_CONFIGURE_HOOKS += HOST_GOOGLE_BREAKPAD_LSS
define GOOGLE_BREAKPAD_LSS
$(INSTALL) -D -m 0644 \
$(STAGING_DIR)/usr/include/linux_syscall_support.h \
$(@D)/src/third_party/lss/linux_syscall_support.h
endef
-GOOGLE_BREAKPAD_POST_EXTRACT_HOOKS += GOOGLE_BREAKPAD_LSS
+GOOGLE_BREAKPAD_PRE_CONFIGURE_HOOKS += GOOGLE_BREAKPAD_LSS
define GOOGLE_BREAKPAD_EXTRACT_SYMBOLS
$(EXTRA_ENV) package/google-breakpad/gen-syms.sh $(STAGING_DIR) \
OpenPOWER on IntegriCloud