summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Mayer <mmayer@broadcom.com>2018-12-20 09:58:11 -0800
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-12-31 14:32:20 +0100
commit375f7488758d8cf75af2b56f2ff01af0eb2de933 (patch)
tree7b21b60cda57cfd4d47d49782eba7324f8d9dc4d
parent2ec38321d6643202c122297878bba88785795a96 (diff)
downloadbuildroot-375f7488758d8cf75af2b56f2ff01af0eb2de933.tar.gz
buildroot-375f7488758d8cf75af2b56f2ff01af0eb2de933.zip
system: introduce BR2_SYSTEM_DEFAULT_PATH option
The configuration option BR2_SYSTEM_DEFAULT_PATH allows the user to override the default path, which can be used by /etc/profile and some system daemons. It defaults to the value previously hard-coded in /etc/profile. This default should be suitable for most users. Signed-off-by: Markus Mayer <mmayer@broadcom.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-rw-r--r--system/Config.in10
-rw-r--r--system/system.mk4
2 files changed, 14 insertions, 0 deletions
diff --git a/system/Config.in b/system/Config.in
index 0f77b9b672..9941807e5d 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -386,6 +386,16 @@ comment "automatic network configuration via DHCP needs ifupdown or busybox or n
endif # BR2_ROOTFS_SKELETON_DEFAULT
+config BR2_SYSTEM_DEFAULT_PATH
+ string "Set the system's default PATH"
+ default "/bin:/sbin:/usr/bin:/usr/sbin"
+ help
+ Sets the system's default PATH. It is being used in
+ /etc/profile in the skeleton-init-common package and by some
+ daemons.
+
+ The default should work in most cases.
+
config BR2_ENABLE_LOCALE_PURGE
bool "Purge unwanted locales"
default y
diff --git a/system/system.mk b/system/system.mk
index ca6bf1388f..8db87cb129 100644
--- a/system/system.mk
+++ b/system/system.mk
@@ -86,3 +86,7 @@ define SYSTEM_REMOUNT_ROOT_INITTAB
$(SED) '/^[^#].*-o remount,rw \/$$/s~^~#~' $(TARGET_DIR)/etc/inittab
endef
endif
+
+ifeq ($(BR_BUILDING)$(BR2_SYSTEM_DEFAULT_PATH),y"")
+$(error BR2_SYSTEM_DEFAULT_PATH can't be empty)
+endif
OpenPOWER on IntegriCloud