summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2018-10-16 14:59:20 -0700
committerEd Tanous <ed.tanous@intel.com>2018-10-22 16:03:59 +0000
commitc85eb8b739db9b0d42d27bf79439508075bbb0eb (patch)
tree77893009778fdc21149e053c1b2d89962917bb24 /CMakeLists.txt
parent43fcbe55bc0917f0bf4a2eaab14dcfbfaf4f9119 (diff)
downloadbmcweb-c85eb8b739db9b0d42d27bf79439508075bbb0eb.tar.gz
bmcweb-c85eb8b739db9b0d42d27bf79439508075bbb0eb.zip
bmcweb: remove warning about coroutines
Boost coroutines seems to be in use in sdbusplus asio, despite its depcrecation in boost. Silence the warning. Change-Id: Ic72545604f597a7ce937710068b040362ab0d224 Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 184a501..80c132b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,6 +114,7 @@ add_definitions (-DBOOST_SYSTEM_NO_DEPRECATED)
add_definitions (-DBOOST_ALL_NO_LIB)
add_definitions (-DBOOST_NO_RTTI)
add_definitions (-DBOOST_NO_TYPEID)
+add_definitions (-DBOOST_COROUTINES_NO_DEPRECATION_WARNING)
find_package (Boost 1.66 REQUIRED)
include_directories (${BOOST_SRC_DIR})
OpenPOWER on IntegriCloud