summaryrefslogtreecommitdiffstats
path: root/meta-rcs/meta-blackbird/recipes-phosphor/ipmi/blackbird-ipmi-inventory-map-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcs/meta-blackbird/recipes-phosphor/ipmi/blackbird-ipmi-inventory-map-native.bb')
-rw-r--r--meta-rcs/meta-blackbird/recipes-phosphor/ipmi/blackbird-ipmi-inventory-map-native.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-rcs/meta-blackbird/recipes-phosphor/ipmi/blackbird-ipmi-inventory-map-native.bb b/meta-rcs/meta-blackbird/recipes-phosphor/ipmi/blackbird-ipmi-inventory-map-native.bb
new file mode 100644
index 000000000..c0620ff5d
--- /dev/null
+++ b/meta-rcs/meta-blackbird/recipes-phosphor/ipmi/blackbird-ipmi-inventory-map-native.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Romulus IPMI to DBus Inventory mapping."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
+
OpenPOWER on IntegriCloud