summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-oe/recipes-graphics/libyui
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/libyui')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch147
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch40
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch49
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0003-Simplify-ncurses-finding-module.patch35
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb10
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch48
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Use-curly-braces-for-MAKE-variable.patch32
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Use-relative-install-paths-for-CMake.patch130
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/libyui/libyui_git.bb13
9 files changed, 406 insertions, 98 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch
new file mode 100644
index 000000000..6d4bdc2ab
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch
@@ -0,0 +1,147 @@
+From 0acfb67f99fd8d6af323311fee8c08116295b148 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 5 Sep 2018 18:21:19 -0700
+Subject: [PATCH 1/2] Use override consistently
+
+Make clang++ happy
+error: 'setApplicationTitle' overrides a member function but is not marked 'override' [-Werror,-Winconsistent-missing-over ride]
+
+Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/69]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/NCApplication.h | 46 ++++++++++++++++++++++-----------------------
+ 1 file changed, 23 insertions(+), 23 deletions(-)
+
+diff --git a/src/NCApplication.h b/src/NCApplication.h
+index e24c3eb..09e4708 100644
+--- a/src/NCApplication.h
++++ b/src/NCApplication.h
+@@ -60,7 +60,7 @@ public:
+ * Reimplemented from YApplication.
+ **/
+ virtual void setLanguage( const std::string & language,
+- const std::string & encoding = std::string() );
++ const std::string & encoding = std::string() ) override;
+
+ /**
+ * Open a directory selection box and prompt the user for an existing
+@@ -77,7 +77,7 @@ public:
+ * Implemented from YApplication.
+ **/
+ virtual std::string askForExistingDirectory( const std::string & startDir,
+- const std::string & headline );
++ const std::string & headline ) override;
+
+ /**
+ * Open a file selection box and prompt the user for an existing file.
+@@ -97,7 +97,7 @@ public:
+ **/
+ virtual std::string askForExistingFile( const std::string & startWith,
+ const std::string & filter,
+- const std::string & headline );
++ const std::string & headline ) override;
+
+ /**
+ * Open a file selection box and prompt the user for a file to save data
+@@ -119,28 +119,28 @@ public:
+ **/
+ virtual std::string askForSaveFileName( const std::string & startWith,
+ const std::string & filter,
+- const std::string & headline );
++ const std::string & headline ) override;
+
+ /**
+ * Beep.
+ *
+ * Reimplemented from YApplication.
+ **/
+- virtual void beep();
++ virtual void beep() override;
+
+ /**
+ * Redraw the screen.
+ *
+ * Reimplemented from YApplication.
+ **/
+- virtual void redrawScreen();
++ virtual void redrawScreen() override;
+
+ /**
+ * Initialize the (text) console keyboard.
+ *
+ * Reimplemented from YApplication.
+ **/
+- virtual void initConsoleKeyboard();
++ virtual void initConsoleKeyboard() override;
+
+ /**
+ * Set the (text) console font according to the current encoding etc.
+@@ -152,7 +152,7 @@ public:
+ const std::string & font,
+ const std::string & screen_map,
+ const std::string & unicode_map,
+- const std::string & language );
++ const std::string & language ) override;
+
+ /**
+ * Run a shell command (typically an interactive program using NCurses)
+@@ -165,7 +165,7 @@ public:
+ *
+ * Reimplemented from YApplication.
+ **/
+- virtual int runInTerminal( const std::string & command );
++ virtual int runInTerminal( const std::string & command ) override;
+
+
+ /// @{
+@@ -183,33 +183,33 @@ public:
+ //
+ // All implemented from YApplication.
+
+- virtual int displayWidth();
+- virtual int displayHeight();
+- virtual int displayDepth();
+- virtual long displayColors();
++ virtual int displayWidth() override;
++ virtual int displayHeight() override;
++ virtual int displayDepth() override;
++ virtual long displayColors() override;
+
+- virtual int defaultWidth();
+- virtual int defaultHeight();
++ virtual int defaultWidth() override;
++ virtual int defaultHeight() override;
+
+- virtual bool isTextMode() { return true; }
++ virtual bool isTextMode() override { return true; }
+
+- virtual bool hasImageSupport() { return false; }
++ virtual bool hasImageSupport() override { return false; }
+
+- virtual bool hasIconSupport() { return false; }
++ virtual bool hasIconSupport() override { return false; }
+
+- virtual bool hasAnimationSupport() { return false; }
++ virtual bool hasAnimationSupport() override { return false; }
+
+- virtual bool hasFullUtf8Support();
+- virtual bool richTextSupportsTable() { return false; }
++ virtual bool hasFullUtf8Support() override;
++ virtual bool richTextSupportsTable() override { return false; }
+
+- virtual bool leftHandedMouse() { return false; }
++ virtual bool leftHandedMouse() override { return false; }
+
+ /**
+ * Set the application title
+ *
+ * Reimplemented from YApplication.
+ **/
+- virtual void setApplicationTitle(const std::string& title);
++ virtual void setApplicationTitle(const std::string& title) override;
+ };
+
+
+--
+2.18.0
+
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch
deleted file mode 100644
index 8e3774c1a..000000000
--- a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 4b84f243a70a8c07f6a38dad3c9411fa707f25c9 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 4 Mar 2018 17:08:43 -0800
-Subject: [PATCH] use _nl_msg_cat_cntr only with glibc
-
-The musl libc provides libintl (similar to glibc)
-but does not use the same internals,
-so even though we are using the GNU gettext
-the libintl included with the libc does not define
-_nl_msg_cat_cntr and it does not need to.
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- src/NCi18n.h | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/NCi18n.h b/src/NCi18n.h
-index 165b0e7..bfc4ed7 100644
---- a/src/NCi18n.h
-+++ b/src/NCi18n.h
-@@ -59,12 +59,13 @@ inline void setTextdomain( const char * domain )
- bindtextdomain( domain, YSettings::localeDir().c_str() );
- bind_textdomain_codeset( domain, "UTF-8" );
- textdomain( domain );
--
-+#if defined(__GLIBC__)
- // Make change known
- {
- extern int _nl_msg_cat_cntr;
- ++_nl_msg_cat_cntr;
- }
-+#endif
- }
-
-
---
-2.16.2
-
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch
new file mode 100644
index 000000000..f65cbe667
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch
@@ -0,0 +1,49 @@
+From 162a0899f1dacd83007c4e82b9034f55610d8c20 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 5 Sep 2018 19:01:51 -0700
+Subject: [PATCH 2/2] Define own resize in NCPad and fix param type of
+ SetLabel()
+
+Explicitly override resize() to avoid conflicts from NCursesWindow
+definition since there is another resize definition as well
+
+Fixes
+src/NCPad.h:164:18: error: 'NCPad::resize' hides overloaded virtual function [-Werror,-Woverloaded-virtual]
+
+NCTablePad.h:132:18: error: 'NCTableTag::SetLabel' hides overloaded virtual function [-Werror,-Woverloaded-virtual]
+
+Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/69]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/NCPad.h | 1 +
+ src/NCTablePad.h | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/NCPad.h b/src/NCPad.h
+index 328c4aa..d8fb324 100644
+--- a/src/NCPad.h
++++ b/src/NCPad.h
+@@ -162,6 +162,7 @@ public:
+ virtual void Destwin( NCursesWindow * dwin );
+
+ virtual void resize( wsze nsze );
++ virtual int resize( int lines, int columns ) { return NCursesWindow::resize(lines, columns );}
+ virtual void wRecoded();
+ virtual void setDirty() { dirty = true; }
+
+diff --git a/src/NCTablePad.h b/src/NCTablePad.h
+index c450529..3756796 100644
+--- a/src/NCTablePad.h
++++ b/src/NCTablePad.h
+@@ -129,7 +129,7 @@ public:
+
+ virtual ~NCTableTag() {}
+
+- virtual void SetLabel( const NCstring & ) { /*NOOP*/; }
++ virtual void SetLabel( const NClabel & ) { /*NOOP*/; }
+
+ virtual void DrawAt( NCursesWindow & w, const wrect at,
+ NCTableStyle & tableStyle,
+--
+2.18.0
+
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0003-Simplify-ncurses-finding-module.patch b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0003-Simplify-ncurses-finding-module.patch
new file mode 100644
index 000000000..2520ac46f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses/0003-Simplify-ncurses-finding-module.patch
@@ -0,0 +1,35 @@
+From c2291fe28dc5682f81804941512431642975cf21 Mon Sep 17 00:00:00 2001
+From: Pascal Bach <pascal.bach@siemens.com>
+Date: Mon, 29 Oct 2018 18:17:32 +0100
+Subject: [PATCH] Simplify ncurses finding module
+
+CMake will automatically look in the right locations, there is no need to
+re-implement the logic with a for loop and NO_DEFAULT_PATH.
+
+It is already done like this to file the headers.
+
+Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/73]
+Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
+---
+ cmake/Modules/FindCurses6.cmake | 8 +++-----
+ 1 file changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/cmake/Modules/FindCurses6.cmake b/cmake/Modules/FindCurses6.cmake
+index 0bf02c3..e298d5d 100644
+--- a/cmake/Modules/FindCurses6.cmake
++++ b/cmake/Modules/FindCurses6.cmake
+@@ -5,11 +5,9 @@
+ # CURSES6_LIBRARIES - The libraries needed to use Curses6
+ # CURSES6_DEFINITIONS - Compiler switches required for using Curses6
+
+-FOREACH(path ${CMAKE_LIBRARY_PATH} /usr/${LIB_DIR})
+- FIND_LIBRARY(CURSES6_NCURSESW_LIBRARY NAMES ncursesw PATHS ${path}/ncurses6 ${path} NO_DEFAULT_PATH)
+- FIND_LIBRARY(CURSES6_PANELW_LIBRARY NAMES panelw PATHS ${path}/ncurses6 ${path} NO_DEFAULT_PATH)
+- FIND_LIBRARY(CURSES6_TINFO_LIBRARY NAMES tinfo PATHS ${path}/ncurses6 ${path} NO_DEFAULT_PATH)
+-ENDFOREACH()
++FIND_LIBRARY(CURSES6_NCURSESW_LIBRARY NAMES ncursesw PATH_SUFFIXES ncurses6)
++FIND_LIBRARY(CURSES6_PANELW_LIBRARY NAMES panelw PATH_SUFFIXES ncurses6)
++FIND_LIBRARY(CURSES6_TINFO_LIBRARY NAMES tinfo PATH_SUFFIXES ncurses6)
+
+ SET(CURSES6_LIBRARIES ${CURSES6_NCURSESW_LIBRARY} ${CURSES6_PANELW_LIBRARY})
+ # tinfo is optional (in 12.1 is not there)
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
index 578c71301..18ea2e828 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb
@@ -5,13 +5,15 @@ LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
"
SRC_URI = "git://github.com/libyui/libyui-ncurses.git \
- file://0001-use-_nl_msg_cat_cntr-only-with-glibc.patch \
+ file://0001-Use-override-consistently.patch \
+ file://0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch \
+ file://0003-Simplify-ncurses-finding-module.patch \
"
SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch"
PV = "2.48.3+git${SRCPV}"
-SRCREV = "79b804b45ffc6a0d92e28e793ff389a20b63b54b"
+SRCREV = "c941b32246e8b2952fce4fd5743f8e318222ab98"
S = "${WORKDIR}/git"
@@ -29,8 +31,8 @@ do_configure_prepend () {
mkdir -p ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/
cp ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so* ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/
cd -
- sed -i "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt
- sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake
+ sed -i -e "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt
+ sed -i -e "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake
}
do_install_append () {
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch
deleted file mode 100644
index c1ba42eee..000000000
--- a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 1e6d40fec16a94d1a4bd40634405267200b7e969 Mon Sep 17 00:00:00 2001
-From: marxin <mliska@suse.cz>
-Date: Tue, 10 Apr 2018 15:21:40 +0200
-Subject: [PATCH] Fix GCC 8 warning:
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-/home/marxin/Programming/libyui/src/YDialog.cc: In static member function ‘static void YDialog::showText(const string&, bool)’:
-/home/marxin/Programming/libyui/src/YDialog.cc:690:26: error: catching polymorphic type ‘class YUIException’ by value [-Werror=catch-value=]
- catch ( YUIException exception )
- ^~~~~~~~~
-/home/marxin/Programming/libyui/src/YDialog.cc: In static member function ‘static bool YDialog::showRelNotesText()’:
-/home/marxin/Programming/libyui/src/YDialog.cc:814:26: error: catching polymorphic type ‘class YUIException’ by value [-Werror=catch-value=]
- catch ( YUIException exception )
- ^~~~~~~~~
----
-Upstream-Status: Submitted [https://github.com/libyui/libyui/pull/122]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
- src/YDialog.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/YDialog.cc b/src/YDialog.cc
-index 92e5031..8ecff90 100644
---- a/src/YDialog.cc
-+++ b/src/YDialog.cc
-@@ -687,7 +687,7 @@ YDialog::showText( const std::string & text, bool useRichText )
- dialog->waitForEvent();
- dialog->destroy();
- }
-- catch ( YUIException exception )
-+ catch ( YUIException &exception )
- {
- // Don't let the application die just because help couldn't be displayed.
-
-@@ -811,7 +811,7 @@ YDialog::showRelNotesText()
- }
- dialog->destroy();
- }
-- catch ( YUIException exception )
-+ catch ( YUIException &exception )
- {
- // Don't let the application die just because RN couldn't be displayed.
-
---
-2.17.0
-
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Use-curly-braces-for-MAKE-variable.patch b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Use-curly-braces-for-MAKE-variable.patch
new file mode 100644
index 000000000..dbe241709
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Use-curly-braces-for-MAKE-variable.patch
@@ -0,0 +1,32 @@
+From 4eed37b1a61458fc8e5251f7cb7c6d64e8e9da8d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 5 Sep 2018 17:48:09 -0700
+Subject: [PATCH] Use curly braces for MAKE variable
+
+Fixes errors with ninja
+| ninja: error: build.ninja:142: bad $-escape (literal $ must be written as $$)
+
+Upstream-Status: Submitted [https://github.com/libyui/libyui/pull/137]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ buildtools/LibyuiCommon.cmake | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/buildtools/LibyuiCommon.cmake b/buildtools/LibyuiCommon.cmake
+index cb93307..e6fbefd 100644
+--- a/buildtools/LibyuiCommon.cmake
++++ b/buildtools/LibyuiCommon.cmake
+@@ -122,8 +122,8 @@ MACRO( SET_BUILD_FLAGS ) # setup compiler-flags depending on CMAKE_BUILD_TYPE
+ ENABLE_TESTING()
+ # add a wrapper "tests" target, the builtin "test" cannot be extended :-(
+ ADD_CUSTOM_TARGET(tests
+- $(MAKE)
+- COMMAND $(MAKE) test
++ ${MAKE}
++ COMMAND ${MAKE} test
+ )
+ ENDIF ( ENABLE_TESTS OR ENABLE_CODE_COVERAGE)
+
+--
+2.18.0
+
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Use-relative-install-paths-for-CMake.patch b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Use-relative-install-paths-for-CMake.patch
new file mode 100644
index 000000000..11a1678a4
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui/0001-Use-relative-install-paths-for-CMake.patch
@@ -0,0 +1,130 @@
+From d24c2516ae25d0ee180c1020e52114ea32230585 Mon Sep 17 00:00:00 2001
+From: Pascal Bach <pascal.bach@siemens.com>
+Date: Mon, 29 Oct 2018 18:03:43 +0100
+Subject: [PATCH] Use relative install paths for CMake
+
+Files are installed via a special _PREFIX variant of the INSTALL_???_DIR
+variable which is an absolute path.
+
+This not only is redundant if CMAKE_INTALL_PREFIX is set but it even causes
+the resulting Config.cmake to be non relocatable. This means it contains absolute
+paths to the build host. This is a problem for cross compilation in Yocto.
+
+This change gets rid of the absolute path and removes the no longer needed
+_PREFIX variants.
+
+Upstream-Status: Submitted [https://github.com/libyui/libyui/pull/140]
+Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
+---
+ buildtools/LibyuiCommon.cmake | 35 ++++++++++++++---------------------
+ 1 file changed, 14 insertions(+), 21 deletions(-)
+
+diff --git a/buildtools/LibyuiCommon.cmake b/buildtools/LibyuiCommon.cmake
+index e6fbefd..5e2fc0d 100644
+--- a/buildtools/LibyuiCommon.cmake
++++ b/buildtools/LibyuiCommon.cmake
+@@ -258,13 +258,6 @@ MACRO( SET_ENVIRONMENT ) # setup the environment vars
+
+ SET( INSTALL_DOC_DIR "${DOC_DIR}" )
+
+- FOREACH( p "DOC" LIB INCLUDE CMAKE PKGCONFIG BUILDTOOLS )
+- SET( var "INSTALL_${p}_DIR" )
+- IF( NOT IS_ABSOLUTE "${${var}}" )
+- SET( ${var}_PREFIX "${YPREFIX}/${${var}}" )
+- ENDIF( NOT IS_ABSOLUTE "${${var}}" )
+- ENDFOREACH()
+-
+ ENDMACRO( SET_ENVIRONMENT )
+
+ MACRO( SET_SONAME )
+@@ -359,7 +352,7 @@ MACRO( SET_AUTODOCS ) # looks for doxygen, dot and latex and setup autodocs acc
+ IF( INSTALL_DOCS OR DOCS_ONLY )
+ INSTALL(
+ FILES "${CMAKE_BINARY_DIR}/doc/latex/refman.pdf"
+- DESTINATION "${INSTALL_DOC_DIR_PREFIX}"
++ DESTINATION "${INSTALL_DOC_DIR}"
+ )
+ ENDIF( INSTALL_DOCS OR DOCS_ONLY )
+
+@@ -379,7 +372,7 @@ MACRO( SET_AUTODOCS ) # looks for doxygen, dot and latex and setup autodocs acc
+ FOREACH( p css gif html jpg js png tag )
+ INSTALL(
+ DIRECTORY "${CMAKE_BINARY_DIR}/doc/html"
+- DESTINATION "${INSTALL_DOC_DIR_PREFIX}"
++ DESTINATION "${INSTALL_DOC_DIR}"
+ FILES_MATCHING PATTERN "*.${p}"
+ )
+ ENDFOREACH()
+@@ -638,32 +631,32 @@ MACRO( SET_INSTALL_TARGET )
+
+ INSTALL(
+ EXPORT ${PROJECTNAME_UC}LibraryDepends
+- DESTINATION "${INSTALL_CMAKE_DIR_PREFIX}"
++ DESTINATION "${INSTALL_CMAKE_DIR}"
+ COMPONENT dev
+ )
+
+ FOREACH( p Config.cmake ConfigVersion.cmake )
+ INSTALL(
+ FILES "${CMAKE_BINARY_DIR}/${PROJECTNAME_UC}${p}"
+- DESTINATION "${INSTALL_CMAKE_DIR_PREFIX}"
++ DESTINATION "${INSTALL_CMAKE_DIR}"
+ )
+ ENDFOREACH( p Config.cmake ConfigVersion.cmake )
+
+ INSTALL(
+ FILES "${CMAKE_BINARY_DIR}/${PROJECTNAME}.pc"
+- DESTINATION "${INSTALL_PKGCONFIG_DIR_PREFIX}"
++ DESTINATION "${INSTALL_PKGCONFIG_DIR}"
+ )
+
+ IF( NOT PLUGINNAME AND NOT EXTENSIONNAME )
+ INSTALL(
+ DIRECTORY "${BUILDTOOLS_DIR}"
+- DESTINATION "${INSTALL_BUILDTOOLS_DIR_PREFIX}"
++ DESTINATION "${INSTALL_BUILDTOOLS_DIR}"
+ )
+ ENDIF( NOT PLUGINNAME AND NOT EXTENSIONNAME )
+
+ INSTALL(
+ FILES ${BUILDTOOLS_LIST}
+- DESTINATION "${INSTALL_BUILDTOOLS_DIR_PREFIX}"
++ DESTINATION "${INSTALL_BUILDTOOLS_DIR}"
+ )
+
+ ENDMACRO( SET_INSTALL_TARGET )
+@@ -724,9 +717,9 @@ MACRO( PROCESS_SOURCES )
+ INSTALL(
+ TARGETS ${TARGETLIB}
+ EXPORT ${PROJECTNAME_UC}LibraryDepends
+- LIBRARY DESTINATION "${INSTALL_LIB_DIR_PREFIX}"
+- ARCHIVE DESTINATION "${INSTALL_LIB_DIR_PREFIX}"
+- PUBLIC_HEADER DESTINATION "${INSTALL_INCLUDE_DIR_PREFIX}"
++ LIBRARY DESTINATION "${INSTALL_LIB_DIR}"
++ ARCHIVE DESTINATION "${INSTALL_LIB_DIR}"
++ PUBLIC_HEADER DESTINATION "${INSTALL_INCLUDE_DIR}"
+ COMPONENT dev
+ )
+
+@@ -746,9 +739,9 @@ MACRO( PROCESS_SOURCES )
+ INSTALL(
+ TARGETS ${TARGETLIB}_static
+ EXPORT ${PROJECTNAME_UC}LibraryDepends
+- LIBRARY DESTINATION "${INSTALL_LIB_DIR_PREFIX}"
+- ARCHIVE DESTINATION "${INSTALL_LIB_DIR_PREFIX}"
+- PUBLIC_HEADER DESTINATION "${INSTALL_INCLUDE_DIR_PREFIX}"
++ LIBRARY DESTINATION "${INSTALL_LIB_DIR}"
++ ARCHIVE DESTINATION "${INSTALL_LIB_DIR}"
++ PUBLIC_HEADER DESTINATION "${INSTALL_INCLUDE_DIR}"
+ COMPONENT dev
+ )
+
+@@ -776,7 +769,7 @@ MACRO( PROCESS_EXAMPLES )
+
+ INSTALL(
+ FILES ${EXAMPLES_LIST}
+- DESTINATION "${INSTALL_DOC_DIR_PREFIX}/examples"
++ DESTINATION "${INSTALL_DOC_DIR}/examples"
+ )
+
+ ENDMACRO( PROCESS_EXAMPLES )
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui_git.bb b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui_git.bb
index 42945288c..d313fb02d 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui_git.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui_git.bb
@@ -6,13 +6,14 @@ LIC_FILES_CHKSUM = "file://COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \
"
SRC_URI = "git://github.com/libyui/libyui.git \
- file://0001-Fix-GCC-8-warning.patch \
file://0001-Fix-build-with-clang.patch \
+ file://0001-Use-curly-braces-for-MAKE-variable.patch \
+ file://0001-Use-relative-install-paths-for-CMake.patch \
"
PV = "3.3.3+git"
-SRCREV = "2b634cb7821e2e79dd4b7a73caf8e67c50189376"
-
+SRCREV = "50672da835ec9d52766320a44a2677e08a24c99c"
+SRCREV_FORMAT = "default"
S = "${WORKDIR}/git"
inherit cmake gettext pkgconfig
@@ -22,9 +23,9 @@ DEPENDS += "boost"
BBCLASSEXTEND = "native nativesdk"
do_configure_prepend () {
- cd ${S}
- ./bootstrap.sh
- cd -
+ (cd ${S} &&
+ ./bootstrap.sh &&
+ cd -)
}
do_install_append () {
OpenPOWER on IntegriCloud