summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-oe/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-bsp')
-rw-r--r--meta-openembedded/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb (renamed from meta-openembedded/meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.16.bb)3
-rw-r--r--meta-openembedded/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch31
-rw-r--r--meta-openembedded/meta-oe/recipes-bsp/efivar/efivar_37.bb (renamed from meta-openembedded/meta-oe/recipes-bsp/efivar/efivar_0.36.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch74
-rw-r--r--meta-openembedded/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb1
5 files changed, 111 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.16.bb b/meta-openembedded/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb
index 6497e0923..4edb2e664 100644
--- a/meta-openembedded/meta-oe/recipes-bsp/efibootmgr/efibootmgr_0.16.bb
+++ b/meta-openembedded/meta-oe/recipes-bsp/efibootmgr/efibootmgr_17.bb
@@ -10,8 +10,9 @@ DEPENDS = "pciutils zlib efivar"
COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
-SRCREV = "a5103251a11663adddc85c86e0b8d3d3b73cbb4a"
+SRCREV = "e067160ecef8208e1944002e5d50b275733211fb"
SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
+ file://0001-remove-extra-decl.patch \
"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch b/meta-openembedded/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch
new file mode 100644
index 000000000..42f3a8182
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-bsp/efibootmgr/files/0001-remove-extra-decl.patch
@@ -0,0 +1,31 @@
+From 99b578501643377e0b1994b2a068b790d189d5ad Mon Sep 17 00:00:00 2001
+From: Peter Jones <pjones@redhat.com>
+Date: Wed, 13 Jun 2018 09:41:01 -0400
+Subject: [PATCH] remove extra decl
+
+Signed-off-by: Peter Jones <pjones@redhat.com>
+
+Upstream-Status: Backport [git://github.com/rhinstaller/efibootmgr.git]
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
+---
+ src/efibootmgr.c | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/src/efibootmgr.c b/src/efibootmgr.c
+index de38f01..4e1a680 100644
+--- a/src/efibootmgr.c
++++ b/src/efibootmgr.c
+@@ -1536,9 +1536,6 @@ parse_opts(int argc, char **argv)
+ "invalid numeric value %s\n",
+ optarg);
+ }
+- /* XXX efivar-36 accidentally doesn't have a public
+- * header for this */
+- extern int efi_set_verbose(int verbosity, FILE *errlog);
+ efi_set_verbose(opts.verbose - 2, stderr);
+ break;
+ case 'V':
+--
+2.7.4
+
diff --git a/meta-openembedded/meta-oe/recipes-bsp/efivar/efivar_0.36.bb b/meta-openembedded/meta-oe/recipes-bsp/efivar/efivar_37.bb
index 20588ee97..8a56e7adc 100644
--- a/meta-openembedded/meta-oe/recipes-bsp/efivar/efivar_0.36.bb
+++ b/meta-openembedded/meta-oe/recipes-bsp/efivar/efivar_37.bb
@@ -12,7 +12,7 @@ inherit pkgconfig
COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
-SRCREV = "ef3449223ecd1e7b1098c523d66b2f960fe839ea"
+SRCREV = "c1d6b10e1ed4ba2be07f385eae5bceb694478a10"
SRC_URI = "git://github.com/rhinstaller/efivar.git \
file://allow-multi-definitions-for-native.patch \
"
@@ -41,3 +41,5 @@ do_install_class-native() {
}
BBCLASSEXTEND = "native"
+
+RRECOMMENDS_${PN} = "kernel-module-efivarfs"
diff --git a/meta-openembedded/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch b/meta-openembedded/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch
new file mode 100644
index 000000000..2d5709f3f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch
@@ -0,0 +1,74 @@
+From dd9b40c54f160a44f1d78e5946d4cd00a8852802 Mon Sep 17 00:00:00 2001
+From: Dengke Du <dengke.du@windriver.com>
+Date: Wed, 21 Sep 2016 03:17:32 -0400
+Subject: [PATCH] lm-sensors: fix sensors-detect can't read the cpu information
+ on fsl-t4xxx
+
+This is because two reasons:
+
+1. The sensors-detect program in lm-sensors depends on the file '/proc/cpuinfo',
+ different arch write different infomation to it. That program supports x86
+ and x86-64 well, but weak on ppc and arm.
+
+2. The sensors-detect program show the cpu information just design for intel's
+ cpu, when meets other arch, it can't output the correct information.
+
+So we need to add the ppc and arm support for this program:
+
+1. add the ppc cpu information field 'cpu' in initialize_cpu_list function.
+
+2. add the correspond case of ppc and arm when print cpu information in
+ print_cpu_info function.
+
+Upstream-Status: Pending
+
+Signed-off-by: Dengke Du <dengke.du@windriver.com>
+---
+ prog/detect/sensors-detect | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/prog/detect/sensors-detect b/prog/detect/sensors-detect
+index 5f62405..ae4def1 100755
+--- a/prog/detect/sensors-detect
++++ b/prog/detect/sensors-detect
+@@ -2833,6 +2833,7 @@ sub kernel_version_at_least
+ # model name and stepping, directly taken from /proc/cpuinfo.
+ use vars qw(@cpu);
+
++# The added field 'cpu' is for support the ppc.
+ sub initialize_cpu_list
+ {
+ local $_;
+@@ -2848,7 +2849,7 @@ sub initialize_cpu_list
+ };
+ next;
+ }
+- if (m/^(vendor_id|cpu family|model|model name|stepping|cpuid level)\s*:\s*(.+)$/) {
++ if (m/^(vendor_id|cpu family|model|model name|stepping|cpuid level|cpu|revision)\s*:\s*(.+)$/) {
+ my $k = $1;
+ my $v = $2;
+ $v =~ s/\s+/ /g; # Merge multiple spaces
+@@ -2861,12 +2862,20 @@ sub initialize_cpu_list
+ push @cpu, $entry if scalar keys(%{$entry}); # Last entry
+ }
+
++# The field 'model name' is for ARM.
++# The field 'cpu' is for ppc.
+ sub print_cpu_info
+ {
+ my $cpu = $cpu[0];
+ if ( $cpu->{'model name'} && $cpu->{'cpu family'} && $cpu->{model} && $cpu->{stepping} ) {
+ print "# Processor: $cpu->{'model name'} ($cpu->{'cpu family'}/$cpu->{model}/$cpu->{stepping})\n";
+ }
++ elsif ( $cpu->{'model name'} ) {
++ print "# Processor: $cpu->{'model name'}\n";
++ }
++ elsif ( $cpu->{'cpu'} && $cpu->{'revision'} ) {
++ print "# Processor: $cpu->{'cpu'} $cpu->{'revision'}\n";
++ }
+ else {
+ print "# Processor: There isn't enough cpu info for this arch!!!\n";
+ }
+--
+2.8.1
+
diff --git a/meta-openembedded/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb b/meta-openembedded/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb
index ffab5d6bf..4dbef73b9 100644
--- a/meta-openembedded/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb
+++ b/meta-openembedded/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb
@@ -12,6 +12,7 @@ SRC_URI = "https://github.com/groeck/lm-sensors/archive/V3-4-0.tar.gz \
file://sensord.init \
file://0001-lmsensors-sensors-detect-print-a-special-message-whe.patch \
file://0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch \
+ file://0001-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch \
"
SRC_URI[md5sum] = "1e9f117cbfa11be1955adc96df71eadb"
SRC_URI[sha256sum] = "e334c1c2b06f7290e3e66bdae330a5d36054701ffd47a5dde7a06f9a7402cb4e"
OpenPOWER on IntegriCloud