summaryrefslogtreecommitdiffstats
path: root/yocto-poky/meta/recipes-devtools/mmc/mmc-utils_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2015-09-15 14:41:29 -0500
committerPatrick Williams <patrick@stwcx.xyz>2015-09-15 14:41:29 -0500
commit21f9b84b4b729fbd7acbd465e7a3f726e4d20f91 (patch)
treeeb2d091d427ca0813b445509d59cc8e27e8ad25f /yocto-poky/meta/recipes-devtools/mmc/mmc-utils_git.bb
parent101cef31e2bf54c678501155cd2106251acbd076 (diff)
parentc124f4f2e04dca16a428a76c89677328bc7bf908 (diff)
downloadblackbird-openbmc-21f9b84b4b729fbd7acbd465e7a3f726e4d20f91.tar.gz
blackbird-openbmc-21f9b84b4b729fbd7acbd465e7a3f726e4d20f91.zip
Merge commit 'c124f4f2e04dca16a428a76c89677328bc7bf908' as 'yocto-poky'
Diffstat (limited to 'yocto-poky/meta/recipes-devtools/mmc/mmc-utils_git.bb')
-rw-r--r--yocto-poky/meta/recipes-devtools/mmc/mmc-utils_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-devtools/mmc/mmc-utils_git.bb b/yocto-poky/meta/recipes-devtools/mmc/mmc-utils_git.bb
new file mode 100644
index 000000000..895036093
--- /dev/null
+++ b/yocto-poky/meta/recipes-devtools/mmc/mmc-utils_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Userspace tools for MMC/SD devices"
+HOMEPAGE = "http://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=17;md5=d7747fc87f1eb22b946ef819969503f0"
+
+BRANCH ?= "master"
+SRCREV = "f4eb241519f8d500ce6068a70d2389be39ac5189"
+
+PV = "0.1"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;branch=${BRANCH} \
+ file://0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch"
+
+S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+ sed -i "s:-Werror::g" ${S}/Makefile
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mmc ${D}${bindir}
+}
OpenPOWER on IntegriCloud