summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-07-08 14:58:53 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 13:53:59 -0400
commit066be20a36c3f99cf5f0ba237f4e464b3378148a (patch)
treeb56c6de5993d3f79d1da0f5551cfb173b84e4ecd /meta-openembedded/meta-python/recipes-devtools/python
parent134b6d49de68990ff80b297e3cb627dc168a497e (diff)
downloadblackbird-openbmc-066be20a36c3f99cf5f0ba237f4e464b3378148a.tar.gz
blackbird-openbmc-066be20a36c3f99cf5f0ba237f4e464b3378148a.zip
meta-openembedded: sumo refresh b0950aeff5..be79b8b111
Update meta-openembedded to sumo HEAD. Armin Kuster (2): wireshark: update to 2.4.7 wireshark: update to 2.4.8 Denys Dmytriyenko (1): devmem2: ensure word is 32-bit, add support for 64-bit long Jagadeesh Krishnanjanappa (1): fuse: CVE-2018-10906 Oleksandr Kravchuk (1): libsodium: update to 1.0.16 changqing.li@windriver.com (1): php: upgrade 7.2.4 -> 7.2.7 Included: leimaohui (2): python-pytest: Fix conflict error as following: libnih: Fix do_package error when enable mutilib. Change-Id: I036baed004e407d5e9fde46eba75b6cc7e3479e0 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc10
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb1
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
index 4feb9a03c..4c32dfb04 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
@@ -9,6 +9,8 @@ SRC_URI[sha256sum] = "117bad36c1a787e1a8a659df35de53ba05f9f3398fb9e4ac17e80ad590
SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
file://pytest_version_fix.patch "
+inherit update-alternatives
+
RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-attrs \
${PYTHON_PN}-debugger \
@@ -22,4 +24,12 @@ RDEPENDS_${PN}_class-target += " \
FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:"
+ALTERNATIVE_${PN} += "py.test pytest"
+
+NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
+ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
+
+ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
+ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
+
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb
index 201ab050c..39e50aca9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest_3.4.2.bb
@@ -6,3 +6,4 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-compiler \
${PYTHON_PN}-funcsigs \
"
+ALTERNATIVE_PRIORITY = "10"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb
index 466cfa825..eba6632a2 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_3.4.2.bb
@@ -1,2 +1,4 @@
inherit pypi setuptools3
require python-pytest.inc
+
+ALTERNATIVE_PRIORITY = "100"
OpenPOWER on IntegriCloud