summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-oe/recipes-support/vim/files/0001-src-Makefile-improve-reproducibility.patch
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2019-02-22 16:03:50 -0600
committerAndrew Geissler <geissonator@yahoo.com>2019-02-22 16:05:07 -0600
commit1548c07ccf17a3a7a4fad7f31fb62d117bcb674f (patch)
treedc38b5d3eba36dab80ecd70556e05f4fae917c12 /meta-openembedded/meta-oe/recipes-support/vim/files/0001-src-Makefile-improve-reproducibility.patch
parent8704effb21a9aac3e4c97d234149887b6acfa941 (diff)
downloadblackbird-openbmc-1548c07ccf17a3a7a4fad7f31fb62d117bcb674f.tar.gz
blackbird-openbmc-1548c07ccf17a3a7a4fad7f31fb62d117bcb674f.zip
meta-openembedded: refresh thud: cca27b5ea7..6ef9657068
Update meta-openembedded to thud HEAD. Alexander Kanavin (2): packagegroup-meta-oe: drop ptest packages that do not exist packagegroup-meta-oe: rename the group that contains ptest packages Andrea Adami (4): klibc: fix build for mipsel and mips64el with security flags enabled waf-cross-answers: Add cross-answers-mips64el.txt kexec-tools-klibc: fix build for mipsel and mips64el samba: fix build on qemumips64 with musl Andreas Müller (1): libgit2: Fix install for multilib Armin Kuster (1): wireshark: update to 2.6.6 Craig McQueen (1): python3-multidict: Workaround for broken make clean Eduardas Meile (1): toybox: fix to use "usrmerge" distro feature properly Haiqing Bai (1): ptpd: fixed the issue of ptpd2 daemon takes 100% CPU Hong Liu (1): wireshark: upgrade to 2.6.5 Hongxu Jia (1): python-pyparted/python3-pyparted: drop incorrect and redundant PV Kai Kang (1): net-snmp: inherit ptest Khem Raj (16): xscreensaver: Define consistent app-defaults dir a2jmidid: Define own do_configure bpftool: don't build under musl packagegroup-meta-oe: Remove arch specific packages as needed packagegroup-meta-oe: Remove packages which don't build for musl modemmanager: Fix build with clang klibc: Fix build with clang srecord: GPL-3.0 and LGPL-3.0 is correct license packagegroup-meta-oe: Exclude unbuildable packages on mips64 packagegroup-meta-oe: Exclude android-tools breakpad on ppc packagegroup-meta-oe: Remove unbuildable packages on risc-v from rdep mpv: Disable lua on mips/aarch64 luajit: Disable for mips n64/n32 hosts licenses: Add Arphic-Public-License text nmap: Fix build with clang8/musl/libc++ mozjs: Fix symbol visibility with clang/libc++ Marc Ferland (1): networkmanager: fix QA issue when using modemmanager and ppp in PACKAGECONFIG Martin Jansa (1): open-vm-tools: fix indentation and drop FILES_${PN}-dbg Mingli Yu (1): vim: improve reproducibility Niko Mauno (7): python-pygobject: Fix invalid install path python-pygobject: Drop redundant PYTHON* refs python-pygobject: Drop redundant dependencies python-pygobject: Only check for even upstream versions python-pygobject: Remove duplication in inherit python-pygobject: Fix style issue python-pygobject: Tune remove operation Otavio Salvador (2): mozjs: Avoid use of X11 from host when X11 is disabled postgresql: Allow successful run of postgresql-setup Primoz Fiser (1): sedutil: fix compile errors on big endian architectures Scott Ellis (2): nmap: Fix typo in pcre PACKAGECONFIG nmap: Include additional FILES path for certs leimaohui (2): mraa: To file do_package error in multilib. makedumpfile: Add aarch64 into COMPATIBLE_HOST. thc (1): fix networkmanager apppend Change-Id: I979f5ccefeec364f27df10888ae6258923a30659 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/vim/files/0001-src-Makefile-improve-reproducibility.patch')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/vim/files/0001-src-Makefile-improve-reproducibility.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/vim/files/0001-src-Makefile-improve-reproducibility.patch b/meta-openembedded/meta-oe/recipes-support/vim/files/0001-src-Makefile-improve-reproducibility.patch
new file mode 100644
index 000000000..63a7b78f1
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/vim/files/0001-src-Makefile-improve-reproducibility.patch
@@ -0,0 +1,46 @@
+From 133ab27cdb17ca20ef6b0304cf30621d2bcbe757 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Thu, 31 Jan 2019 21:32:26 -0800
+Subject: [PATCH] src/Makefile: improve reproducibility
+
+Clear all_cflags, all_lflags, compiled_user
+and compiled_sys to avoid introducing build
+info to improve reproducibility as below:
+
+WARNING: vim-8.1.0347-r0 do_package_qa: QA Issue: File /work/core2-64-wrs-linux/vim/8.1.0347-r0/packages-split/vim/usr/bin/vim.vim in package contained reference to tmpdir [buildpaths]
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ src/Makefile | 14 ++++----------
+ 1 file changed, 4 insertions(+), 10 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index f2fafa4dc..7148d4bd9 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -2845,16 +2845,10 @@ auto/pathdef.c: Makefile auto/config.mk
+ -@echo '#include "vim.h"' >> $@
+ -@echo 'char_u *default_vim_dir = (char_u *)"$(VIMRCLOC)";' | $(QUOTESED) >> $@
+ -@echo 'char_u *default_vimruntime_dir = (char_u *)"$(VIMRUNTIMEDIR)";' | $(QUOTESED) >> $@
+- -@echo 'char_u *all_cflags = (char_u *)"$(CC) -c -I$(srcdir) $(ALL_CFLAGS)";' | $(QUOTESED) >> $@
+- -@echo 'char_u *all_lflags = (char_u *)"$(CC) $(ALL_LIB_DIRS) $(LDFLAGS) -o $(VIMTARGET) $(ALL_LIBS) ";' | $(QUOTESED) >> $@
+- -@echo 'char_u *compiled_user = (char_u *)"' | tr -d $(NL) >> $@
+- -@if test -n "$(COMPILEDBY)"; then \
+- echo "$(COMPILEDBY)" | tr -d $(NL) >> $@; \
+- else ((logname) 2>/dev/null || whoami) | tr -d $(NL) >> $@; fi
+- -@echo '";' >> $@
+- -@echo 'char_u *compiled_sys = (char_u *)"' | tr -d $(NL) >> $@
+- -@if test -z "$(COMPILEDBY)"; then hostname | tr -d $(NL) >> $@; fi
+- -@echo '";' >> $@
++ -@echo 'char_u *all_cflags = (char_u *)"";' | $(QUOTESED) >> $@
++ -@echo 'char_u *all_lflags = (char_u *)"";' | $(QUOTESED) >> $@
++ -@echo 'char_u *compiled_user = (char_u *)"";' >> $@
++ -@echo 'char_u *compiled_sys = (char_u *)"";' >> $@
+ -@sh $(srcdir)/pathdef.sh
+
+ GUI_GTK_RES_INPUTS = \
+--
+2.17.1
+
OpenPOWER on IntegriCloud