summaryrefslogtreecommitdiffstats
path: root/import-layers/yocto-poky/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-08-17 14:31:25 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-08-22 16:43:26 +0000
commit60f9d69e016b11c468c98ea75ba0a60c44afbbc4 (patch)
treeecb49581a9e41a37943c22cd9ef3f63451b20ee7 /import-layers/yocto-poky/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
parente18c61205e0234b03697129c20cc69c9b3940efc (diff)
downloadblackbird-openbmc-60f9d69e016b11c468c98ea75ba0a60c44afbbc4.tar.gz
blackbird-openbmc-60f9d69e016b11c468c98ea75ba0a60c44afbbc4.zip
yocto-poky: Move to import-layers subdir
We are going to import additional layers, so create a subdir to hold all of the layers that we import with git-subtree. Change-Id: I6f732153a22be8ca663035c518837e3cc5ec0799 Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'import-layers/yocto-poky/meta-skeleton/recipes-kernel/hello-mod/files/Makefile')
-rw-r--r--import-layers/yocto-poky/meta-skeleton/recipes-kernel/hello-mod/files/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/import-layers/yocto-poky/meta-skeleton/recipes-kernel/hello-mod/files/Makefile b/import-layers/yocto-poky/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
new file mode 100644
index 000000000..4ded35fbc
--- /dev/null
+++ b/import-layers/yocto-poky/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
@@ -0,0 +1,14 @@
+obj-m := hello.o
+
+SRC := $(shell pwd)
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
+ rm -f Module.markers Module.symvers modules.order
+ rm -rf .tmp_versions Modules.symvers
OpenPOWER on IntegriCloud