summaryrefslogtreecommitdiffstats
path: root/board/esd/common
Commit message (Collapse)AuthorAgeFilesLines
* mtd: nand: Add+use mtd_to/from_nand and nand_get/set_controller_dataScott Wood2016-06-031-1/+1
| | | | | | | | | These functions are part of the Linux 4.6 sync. They are being added before the main sync patch in order to make it easier to address the issue across all NAND drivers (many/most of which do not closely track their Linux counterparts) separately from other merge issues. Signed-off-by: Scott Wood <oss@buserror.net>
* Move console definitions into a new console.h fileSimon Glass2015-11-191-0/+1
| | | | | | | | The console includes a global variable and several functions that are only used by a small subset of U-Boot files. Before adding more functions, move the definitions into their own header file. Signed-off-by: Simon Glass <sjg@chromium.org>
* ppc4xx: cleanup CPCI4052 boardMatthias Fuchs2015-01-132-518/+0
| | | | | | | - remove some obsolete code - switch to generic board Signed-off-by: Matthias Fuchs <matthias.fuchs@esd.eu>
* fat: Prepare API change for files greater than 2GBSuriyan Ramasami2014-11-231-3/+0
| | | | | | | | | Change the internal FAT functions to use loff_t for offsets. Signed-off-by: Suriyan Ramasami <suriyan.r@gmail.com> Acked-by: Simon Glass <sjg@chromium.org> [trini: Fix fs/fat/fat.c for min3 updates] Signed-off-by: Tom Rini <trini@ti.com>
* board/esd/common/auto_update.c: Use <flash.h>Tom Rini2014-11-231-3/+1
| | | | | | A number of prototypes here are now found in <flash.h>. use. Signed-off-by: Tom Rini <trini@ti.com>
* board/esd/common/auto_update.c: fix Uninitialized variableWolfgang Denk2014-11-101-2/+1
| | | | | | | | | | | | cppcheck reports: [board/esd/common/auto_update.c:458]: (error) Uninitialized variable: cnt The variable is not really used anywhere, so remove it. Signed-off-by: Wolfgang Denk <wd@denx.de> Cc: Matthias Fuchs <matthias.fuchs@esd-electronics.com> Acked-by: Matthias Fuchs <matthias.fuchs@esd.eu>
* esd:cmd_loadpci.c: Switch from "do_source" to "source"Tom Rini2014-07-221-7/+1
| | | | | | | | Rather than calling do_source directly (which is not officially exported from cmd_source.c) call 'source' which is exported and requires a little less code to do so as well. Signed-off-by: Tom Rini <trini@ti.com>
* board: delete unused header filesMasahiro Yamada2014-01-241-120/+0
| | | | | | Signed-off-by: Masahiro Yamada <yamada.m@jp.panasonic.com> Acked-by: Stefan Roese <sr@denx.de> Acked-by: Matthias Fuchs <matthias.fuchs@esd.eu>
* Coding Style cleanup: replace leading SPACEs by TABsWolfgang Denk2013-10-141-1/+1
| | | | | | Signed-off-by: Wolfgang Denk <wd@denx.de> [trini: Drop changes for PEP 4 following python tools] Signed-off-by: Tom Rini <trini@ti.com>
* Add GPL-2.0+ SPDX-License-Identifier to source filesWolfgang Denk2013-07-2423-391/+23
| | | | | | Signed-off-by: Wolfgang Denk <wd@denx.de> [trini: Fixup common/cmd_io.c] Signed-off-by: Tom Rini <trini@ti.com>
* Consolidate bool typeYork Sun2013-04-012-10/+5
| | | | | | | | | | | | | 'bool' is defined in random places. This patch consolidates them into a single header file include/linux/types.h, using stdbool.h introduced in C99. All other #define, typedef and enum are removed. They are all consistent with true = 1, false = 0. Replace FALSE, False with false. Replace TRUE, True with true. Skip *.py, *.php, lib/* files. Signed-off-by: York Sun <yorksun@freescale.com>
* Stop using builtin_run_command()Simon Glass2012-03-062-2/+2
| | | | | | | | | | Boards can select either the 'built-in' parser or the hush parser. We should not call builtin_run_command() if we are using the hush parser. We use run_command() instead, since it knows how to call the correct parser. Signed-off-by: Simon Glass <sjg@chromium.org> Acked-by: Mike Frysinger <vapier@gentoo.org>
* Rename run_command() to builtin_run_command()Simon Glass2012-03-062-2/+2
| | | | | | | | | The current run_command() is only one of the parsing options - the other is hush. We should not call run_command() when the hush parser is being used. So we rename this function to better explain its purpose. Signed-off-by: Simon Glass <sjg@chromium.org> Acked-by: Mike Frysinger <vapier@gentoo.org>
* board/esd/common/xilinx_jtag_micro.c: Fix GCC 4.6 warningMatthias Fuchs2011-12-021-2/+0
| | | | Signed-off-by: Matthias Fuchs <matthias.fuchs@esd.eu>
* auto_update.c: Fix GCC 4.6 build warningsStefan Roese2011-11-161-7/+1
| | | | | | | | | | Fix: ../common/auto_update.c: In function 'au_check_header_valid': ../common/auto_update.c:94:16: warning: variable 'checksum' set but not used [-Wunused-but-set-variable] ../common/auto_update.c: In function 'do_auto_update': ../common/auto_update.c:400:30: warning: variable 'got_ctrlc' set but not used [-Wunused-but-set-variable] Signed-off-by: Stefan Roese <sr@denx.de>
* do_bootm: unify duplicate prototypesMike Frysinger2010-11-281-1/+0
| | | | | | | | The duplication of the do_bootm prototype has gotten out of hand, and they're pretty much all outdated (wrt constness). Unify them all in command.h. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
* ppc4xx: Move ppc4xx headers to powerpc include directoryStefan Roese2010-09-232-2/+2
| | | | | | | | | This patch moves some ppc4xx related headers from the common include directory (include/) to the powerpc specific one (arch/powerpc/include/asm/). This way to common include directory is not so cluttered with files. Signed-off-by: Stefan Roese <sr@denx.de>
* cmd_usage(): simplify return code handlingWolfgang Denk2010-07-241-4/+2
| | | | | | | | | | | | | | | | Lots of code use this construct: cmd_usage(cmdtp); return 1; Change cmd_usage() let it return 1 - then we can replace all these ocurrances by return cmd_usage(cmdtp); This fixes a few places with incorrect return code handling, too. Signed-off-by: Wolfgang Denk <wd@denx.de>
* Make sure that argv[] argument pointers are not modified.Wolfgang Denk2010-07-044-4/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The hush shell dynamically allocates (and re-allocates) memory for the argument strings in the "char *argv[]" argument vector passed to commands. Any code that modifies these pointers will cause serious corruption of the malloc data structures and crash U-Boot, so make sure the compiler can check that no such modifications are being done by changing the code into "char * const argv[]". This modification is the result of debugging a strange crash caused after adding a new command, which used the following argument processing code which has been working perfectly fine in all Unix systems since version 6 - but not so in U-Boot: int main (int argc, char **argv) { while (--argc > 0 && **++argv == '-') { /* ====> */ while (*++*argv) { switch (**argv) { case 'd': debug++; break; ... default: usage (); } } } ... } The line marked "====>" will corrupt the malloc data structures and usually cause U-Boot to crash when the next command gets executed by the shell. With the modification, the compiler will prevent this with an error: increment of read-only location '*argv' N.B.: The code above can be trivially rewritten like this: while (--argc > 0 && **++argv == '-') { char *arg = *argv; while (*++arg) { switch (*arg) { ... Signed-off-by: Wolfgang Denk <wd@denx.de> Acked-by: Mike Frysinger <vapier@gentoo.org>
* License cleanup: Fix license header for some esd display configurationsMatthias Fuchs2009-10-246-44/+102
| | | | | | | | | | | These files were autogenerated by EPSON configuration tools. This patch replaces the autogenerated file headers by the GPL license notice. This change is done with the explicit permission of Epson Research & Development / IC Software Development. Signed-off-by: Matthias Fuchs <matthias.fuchs@esd.eu>
* ppc_4xx: Apply new HW register namesNiklaus Giger2009-10-071-1/+1
| | | | | | | | Modify all existing *.c files to use the new register names as seen in the AMCC manuals. Signed-off-by: Niklaus Giger <niklaus.giger@member.fsf.org> Signed-off-by: Stefan Roese <sr@denx.de>
* board/esd/common/flash.c: Fix compile warningWolfgang Denk2009-09-151-1/+2
| | | | | | | | | | | Fix warning: ../common/flash.c:635: warning: dereferencing type-punned pointer will break strict-aliasing rules Signed-off-by: Wolfgang Denk <wd@denx.de> Cc: Matthias Fuchs <matthias.fuchs@esd-electronics.com> Cc: Stefan Roese <sr@denx.de> Acked-by: Matthias Fuchs <matthias.fuchs@esd.eu> Acked-by: Stefan Roese <sr@denx.de>
* Remove legacy NAND and disk on chip references from boards.Scott Wood2009-07-171-50/+0
| | | | Signed-off-by: Scott Wood <scottwood@freescale.com>
* General help message cleanupWolfgang Denk2009-06-124-5/+5
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Many of the help messages were not really helpful; for example, many commands that take no arguments would not print a correct synopsis line, but "No additional help available." which is not exactly wrong, but not helpful either. Commit ``Make "usage" messages more helpful.'' changed this partially. But it also became clear that lots of "Usage" and "Help" messages (fields "usage" and "help" in struct cmd_tbl_s respective) were actually redundant. This patch cleans this up - for example: Before: => help dtt dtt - Digital Thermometer and Thermostat Usage: dtt - Read temperature from digital thermometer and thermostat. After: => help dtt dtt - Read temperature from Digital Thermometer and Thermostat Usage: dtt Signed-off-by: Wolfgang Denk <wd@denx.de>
* esd/common: extend cpld command with address parameterMatthias Fuchs2009-06-122-14/+20
| | | | | | | | | This patch adds support for an address parameter to esd's cpld command. This is in preparation to remove compiled-in binary cpld (xsvf) bitstreams. Signed-off-by: Matthias Fuchs <matthias.fuchs@esd.eu> Signed-off-by: Stefan Roese <sr@denx.de>
* Fix e-mail address of Gary Jennejohn.Detlev Zundel2009-05-151-1/+1
| | | | Signed-off-by: Detlev Zundel <dzu@denx.de>
* Add "source" command; prepare removal of "autoscr" commandWolfgang Denk2009-04-031-3/+3
| | | | | | | | | | | | | | | | | | | | | According to the doc/feature-removal-schedule.txt, the "autoscr" command will be replaced by the "source" command in approximately 6 months from now. This patch prepares this change and starts a 6 month transition period as follows: - The new "source" command has been added, which implements exactly the same functionlaity as the old "autoscr" command before - The old "autoscr" command name is kept as an alias for compatibility - Command sequences, script files atc. have been adapted to use the new "source" command - Related environment variables ("autoscript", "autoscript_uname") have *not* been adapted yet; these will be renamed resp. removed in a separate patch when the support for the "autoscr" command get's finally dropped. Signed-off-by: Wolfgang Denk <wd@denx.de>
* ppc4xx: Use correct io accessors for esd 405/440 boardsMatthias Fuchs2009-03-203-14/+19
| | | | | | | | | This patch replaces in/out8/16/32 macros by in/out_8/_be16/_be32 macros. Also volatile pointer references are replaced by the new accessors. Signed-off-by: Matthias Fuchs <matthias.fuchs@esd.eu> Signed-off-by: Stefan Roese <sr@denx.de>
* pci: Rename PCI_REGION_MEMORY to PCI_REGION_SYS_MEMORY for clarityKumar Gala2009-02-071-1/+1
| | | | | | | | | | The PCI_REGION_MEMORY and PCI_REGION_MEM are a bit to similar and can be confusing when reading the code. Rename PCI_REGION_MEMORY to PCI_REGION_SYS_MEMORY to clarify its used for system memory mapping purposes. Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
* Command usage cleanupPeter Tyser2009-01-284-4/+4
| | | | | | | | Remove command name from all command "usage" fields and update common/command.c to display "name - usage" instead of just "usage". Also remove newlines from command usage fields. Signed-off-by: Peter Tyser <ptyser@xes-inc.com>
* Standardize command usage messages with cmd_usage()Peter Tyser2009-01-281-1/+1
| | | | Signed-off-by: Peter Tyser <ptyser@xes-inc.com>
* ppc4xx: Fix esd loadpci commandMatthias Fuchs2008-10-311-8/+16
| | | | | | | | This patch fixes esd's loadpci command when not all memory on adapter boards is accessable via PCI. Signed-off-by: Matthias Fuchs <matthias.fuchs@esd-electronics.com> Signed-off-by: Stefan Roese <sr@denx.de>
* rename CFG_ macros to CONFIG_SYSJean-Christophe PLAGNIOL-VILLARD2008-10-187-122/+122
| | | | Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
* drivers/mtd/nand: Move conditional compilation to MakefileJean-Christophe PLAGNIOL-VILLARD2008-08-131-6/+6
| | | | | | rename CFG_NAND_LEGACY to CONFIG_NAND_LEGACY Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
* Fixing coding style issuesWilliam Juul2008-08-121-3/+3
| | | | | | | | | - Fixing leading white spaces - Fixing indentation where 4 spaces are used instead of tab - Removing C++ comments (//), wherever I introduced them Signed-off-by: William Juul <william.juul@tandberg.com> Signed-off-by: Scott Wood <scottwood@freescale.com>
* Update MTD to that of Linux 2.6.22.1William Juul2008-08-121-22/+20
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | A lot changed in the Linux MTD code, since it was last ported from Linux to U-Boot. This patch takes U-Boot NAND support to the level of Linux 2.6.22.1 and will enable support for very large NAND devices (4KB pages) and ease the compatibility between U-Boot and Linux filesystems. This patch is tested on two custom boards with PPC and ARM processors running YAFFS in U-Boot and Linux using gcc-4.1.2 cross compilers. MAKEALL ppc/arm has some issues: * DOC/OneNand/nand_spl is not building (I have not tried porting these parts, and since I do not have any HW and I am not familiar with this code/HW I think its best left to someone else.) Except for the issues mentioned above, I have ported all drivers necessary to run MAKEALL ppc/arm without errors and warnings. Many drivers were trivial to port, but some were not so trivial. The following drivers must be examined carefully and maybe rewritten to some degree: cpu/ppc4xx/ndfc.c cpu/arm926ejs/davinci/nand.c board/delta/nand.c board/zylonite/nand.c Signed-off-by: William Juul <william.juul@tandberg.com> Signed-off-by: Stig Olsen <stig.olsen@tandberg.com> Signed-off-by: Scott Wood <scottwood@freescale.com>
* Fix compilation error for TASREGTsiChung Liew2008-08-011-0/+2
| | | | | | | TASREG is ColdFire platform, the include ppc4xx.h in board/esd/common/flash.c causes conflict. Signed-off-by: TsiChung Liew <Tsi-Chung.Liew@freescale.com>
* ppc4xx: Small coding style cleanup for the latest esd patchesStefan Roese2008-04-221-1/+0
| | | | Signed-off-by: Stefan Roese <sr@denx.de>
* ppc4xx: update esd's common auto_update code for 405 boardsMatthias Fuchs2008-04-222-117/+106
| | | | | | | | - Coding style cleanup (long lines) - improve handling of protected flash regions - remove dead code Signed-off-by: Matthias Fuchs <matthias.fuchs@esd-electronics.com>
* ppc4xx: Update esd's common LCD code for 405 boardsMatthias Fuchs2008-04-222-38/+151
| | | | | | | | - Coding style cleanup (long lines) - Add s1d13505 support - Make some functions return a result code instead of void Signed-off-by: Matthias Fuchs <matthias.fuchs@esd-electronics.com>
* Merge branch 'master' of git://www.denx.de/git/u-boot into new-imageMarian Balakowicz2008-03-121-176/+167
|\
| * esd/common/fpga.c: fix indentation.Wolfgang Denk2008-03-091-177/+167
| | | | | | | | Signed-off-by: Wolfgang Denk <wd@denx.de>
| * esd/common/fpga.c: fix 'assignment of read-only location' errorWolfgang Denk2008-03-091-3/+4
| | | | | | | | Signed-off-by: Wolfgang Denk <wd@denx.de>
| * esd: Fix warning: passing argument 1 of 'fpga_boot' discards qualifiers from ↵Jean-Christophe PLAGNIOL-VILLARD2008-03-081-1/+1
| | | | | | | | | | | | pointer target type Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
* | [new uImage] Update naming convention for bootm/uImage related codeMarian Balakowicz2008-02-291-3/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This patch introduces the following prefix convention for the image format handling and bootm related code: genimg_ - dual format shared code image_ - legacy uImage format specific code fit_ - new uImage format specific code boot_ - booting process related code Related routines are renamed and a few pieces of code are moved around and re-grouped. Signed-off-by: Marian Balakowicz <m8@semihalf.com>
* | [new uImage] Add dual format uImage support frameworkMarian Balakowicz2008-02-251-0/+19
| | | | | | | | | | | | | | | | | | | | | | | | | | | | This patch adds framework for dual format images. Format detection is added and the bootm controll flow is updated to include cases for new FIT format uImages. When the legacy (image_header based) format is detected appropriate legacy specific handling is invoked. For the new (FIT based) format uImages dual boot framework has a minial support, that will only print out a corresponding debug messages. Implementation of the FIT specific handling will be added in following patches. Signed-off-by: Marian Balakowicz <m8@semihalf.com>
* | [new uImage] Define a API for image handling operationsMarian Balakowicz2008-02-071-40/+33
|/ | | | | | | | | - Add inline helper macros for basic header processing - Move common non inline code common/image.c - Replace direct header access with the API routines - Rename IH_CPU_* to IH_ARCH_* Signed-off-by: Marian Balakowicz <m8@semihalf.com>
* ppc4xx: More cleanup for esd's LCD codeMatthias Fuchs2008-01-041-20/+18
| | | | Signed-off-by: Matthias Fuchs <matthias.fuchs@esd-electronics.com>
* ppc4xx: Coding style cleanupStefan Roese2007-12-281-17/+11
| | | | Signed-off-by: Stefan Roese <sr@denx.de>
* ppc4xx: use correct io accessors for esd's LCD codeMatthias Fuchs2007-12-281-7/+8
| | | | | | | This patch fixes esd's LCD dectection code to work correctly with newer gcc versions. Signed-off-by: Matthias Fuchs <matthias.fuchs@esd-electronics.com>
OpenPOWER on IntegriCloud