summaryrefslogtreecommitdiffstats
path: root/libs/printf/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Lojewski <github@meklort.com>2019-06-22 18:01:29 -0600
committerEvan Lojewski <github@meklort.com>2019-06-22 18:01:29 -0600
commitb4668768e1281ad943cc04deca0bd5feabd3b448 (patch)
tree56f6e0c72b4ad3ec0eed2095e3441b2432c8720a /libs/printf/CMakeLists.txt
parenta8dbe49f6c799f213d68b013c7961c591e019f03 (diff)
downloadbcm5719-ortega-b4668768e1281ad943cc04deca0bd5feabd3b448.tar.gz
bcm5719-ortega-b4668768e1281ad943cc04deca0bd5feabd3b448.zip
Add a simple printf implimentation to the APE firmware.
Diffstat (limited to 'libs/printf/CMakeLists.txt')
-rw-r--r--libs/printf/CMakeLists.txt69
1 files changed, 69 insertions, 0 deletions
diff --git a/libs/printf/CMakeLists.txt b/libs/printf/CMakeLists.txt
new file mode 100644
index 0000000..e3ced91
--- /dev/null
+++ b/libs/printf/CMakeLists.txt
@@ -0,0 +1,69 @@
+################################################################################
+###
+### @file libs/Ethernet/CMakeLists.txt
+###
+### @project
+###
+### @brief Ethernet CMake file
+###
+################################################################################
+###
+################################################################################
+###
+### @copyright Copyright (c) 2019, Evan Lojewski
+### @cond
+###
+### All rights reserved.
+###
+### Redistribution and use in source and binary forms, with or without
+### modification, are permitted provided that the following conditions are met:
+### 1. Redistributions of source code must retain the above copyright notice,
+### this list of conditions and the following disclaimer.
+### 2. Redistributions in binary form must reproduce the above copyright notice,
+### this list of conditions and the following disclaimer in the documentation
+### and/or other materials provided with the distribution.
+### 3. Neither the name of the copyright holder nor the
+### names of its contributors may be used to endorse or promote products
+### derived from this software without specific prior written permission.
+###
+################################################################################
+###
+### THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+### AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+### IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+### ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+### LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+### CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+### SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+### INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+### CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+### ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+### POSSIBILITY OF SUCH DAMAGE.
+### @endcond
+################################################################################
+
+project(printf)
+
+SET(SOURCES
+ printf.c
+# include/NCSI.h
+# include/Ethernet.h
+)
+
+add_definitions(-DPRINTF_DISABLE_SUPPORT_FLOAT -DPRINTF_DISABLE_SUPPORT_LONG_LONG)
+
+# Host Simulation library
+simulator_add_library(${PROJECT_NAME} STATIC ${SOURCES})
+target_link_libraries(${PROJECT_NAME} PRIVATE simulator Network MII APE)
+target_include_directories(${PROJECT_NAME} PUBLIC ../../include)
+target_include_directories(${PROJECT_NAME} PUBLIC .)
+
+# ARM Library
+arm_add_library(${PROJECT_NAME}-arm STATIC ${SOURCES} ape_putchar.c)
+target_link_libraries(${PROJECT_NAME}-arm PRIVATE Network-arm MII-arm APE-arm)
+target_include_directories(${PROJECT_NAME}-arm PUBLIC ../../include)
+target_include_directories(${PROJECT_NAME}-arm PUBLIC .)
+
+format_target_sources(${PROJECT_NAME})
+
+# add_subdirectory(tests)
OpenPOWER on IntegriCloud