summaryrefslogtreecommitdiffstats
path: root/libs/printf/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Lojewski <github@meklort.com>2019-12-28 20:28:56 -0700
committerGitHub <noreply@github.com>2019-12-28 20:28:56 -0700
commitae757bb328dcc1eb6bbc703ac0606013f4e729da (patch)
tree7b1ac8860a50266eeb129546fbc2498396c333d7 /libs/printf/CMakeLists.txt
parente0912558b571ce29e2d48cf2c9d7b97ded57ac42 (diff)
downloadbcm5719-ortega-ae757bb328dcc1eb6bbc703ac0606013f4e729da.tar.gz
bcm5719-ortega-ae757bb328dcc1eb6bbc703ac0606013f4e729da.zip
stage1: Enable spi printouts when running from the RX CPU. (#9)
- Also fix an issue with the linker script that could cause bss initialization to be misaligned.
Diffstat (limited to 'libs/printf/CMakeLists.txt')
-rw-r--r--libs/printf/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/libs/printf/CMakeLists.txt b/libs/printf/CMakeLists.txt
index 2caa5fe..bb4dca2 100644
--- a/libs/printf/CMakeLists.txt
+++ b/libs/printf/CMakeLists.txt
@@ -46,6 +46,7 @@ project(printf)
SET(SOURCES
printf.c
+ em100_putchar.c
# include/NCSI.h
# include/Ethernet.h
)
@@ -54,7 +55,7 @@ add_definitions(-DPRINTF_DISABLE_SUPPORT_FLOAT -DPRINTF_DISABLE_SUPPORT_LONG_LON
# Host Simulation library
simulator_add_library(${PROJECT_NAME} STATIC ${SOURCES})
-target_link_libraries(${PROJECT_NAME} PRIVATE simulator Network MII APE)
+target_link_libraries(${PROJECT_NAME} PRIVATE simulator Network MII APE NVRam)
target_include_directories(${PROJECT_NAME} PUBLIC ../../include)
target_include_directories(${PROJECT_NAME} PUBLIC .)
@@ -64,6 +65,12 @@ target_link_libraries(${PROJECT_NAME}-arm PRIVATE Network-arm MII-arm APE-arm NV
target_include_directories(${PROJECT_NAME}-arm PUBLIC ../../include)
target_include_directories(${PROJECT_NAME}-arm PUBLIC .)
+# MIPS Library
+mips_add_library(${PROJECT_NAME}-mips STATIC em100_putchar.c mips_putchar.c)
+target_link_libraries(${PROJECT_NAME}-mips PRIVATE NVRam-mips)
+target_include_directories(${PROJECT_NAME}-mips PUBLIC ../../include)
+target_include_directories(${PROJECT_NAME}-mips PUBLIC .)
+
format_target_sources(${PROJECT_NAME})
# add_subdirectory(tests)
OpenPOWER on IntegriCloud