summaryrefslogtreecommitdiffstats
path: root/libs/printf/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Lojewski <github@meklort.com>2020-10-16 23:19:35 -0600
committerGitHub <noreply@github.com>2020-10-16 23:19:35 -0600
commit014bd41470af7f6ed0d6a1701891d4b5ac9b7f96 (patch)
treeb724d29c1d87ccd8ab2cf8c5091d41f60bcccccd /libs/printf/CMakeLists.txt
parent272d17ed7cc17637808c09ab48478562a1bab520 (diff)
downloadbcm5719-ortega-014bd41470af7f6ed0d6a1701891d4b5ac9b7f96.tar.gz
bcm5719-ortega-014bd41470af7f6ed0d6a1701891d4b5ac9b7f96.zip
printf: Cleanup various linting warnings. (#144)
Diffstat (limited to 'libs/printf/CMakeLists.txt')
-rw-r--r--libs/printf/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/libs/printf/CMakeLists.txt b/libs/printf/CMakeLists.txt
index bb4dca2..b95218f 100644
--- a/libs/printf/CMakeLists.txt
+++ b/libs/printf/CMakeLists.txt
@@ -1,10 +1,10 @@
################################################################################
###
-### @file libs/Ethernet/CMakeLists.txt
+### @file libs/printf/CMakeLists.txt
###
-### @project
+### @project bcm5719-fw
###
-### @brief Ethernet CMake file
+### @brief printf CMake file
###
################################################################################
###
@@ -52,6 +52,7 @@ SET(SOURCES
)
add_definitions(-DPRINTF_DISABLE_SUPPORT_FLOAT -DPRINTF_DISABLE_SUPPORT_LONG_LONG)
+set_source_files_properties(printf.c PROPERTIES COMPILE_DEFINITIONS "NO_FLINT") # Disable linting
# Host Simulation library
simulator_add_library(${PROJECT_NAME} STATIC ${SOURCES})
OpenPOWER on IntegriCloud