summaryrefslogtreecommitdiffstats
path: root/lldb/tools/debugserver/source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lldb/tools/debugserver/source/CMakeLists.txt')
-rw-r--r--lldb/tools/debugserver/source/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/lldb/tools/debugserver/source/CMakeLists.txt b/lldb/tools/debugserver/source/CMakeLists.txt
index dd5895adc29..b763c7cfa4d 100644
--- a/lldb/tools/debugserver/source/CMakeLists.txt
+++ b/lldb/tools/debugserver/source/CMakeLists.txt
@@ -209,12 +209,11 @@ endif()
set(entitlements_xml ${CMAKE_CURRENT_SOURCE_DIR}/debugserver-macosx-entitlements.plist)
if(IOS)
set(entitlements_xml ${CMAKE_CURRENT_SOURCE_DIR}/debugserver-entitlements.plist)
+else()
+ set(entitlements_xml ${CMAKE_CURRENT_SOURCE_DIR}/../../../resources/debugserver-macosx-entitlements.plist)
endif()
set(LLDB_USE_ENTITLEMENTS_Default On)
-if("${LLDB_CODESIGN_IDENTITY}" STREQUAL "lldb_codesign")
- set(LLDB_USE_ENTITLEMENTS_Default Off)
-endif()
option(LLDB_USE_ENTITLEMENTS "Use entitlements when codesigning (Defaults Off when using lldb_codesign identity, otherwise On)" ${LLDB_USE_ENTITLEMENTS_Default})
if (SKIP_DEBUGSERVER)
OpenPOWER on IntegriCloud