summaryrefslogtreecommitdiffstats
path: root/lldb/packages/Python/lldbsuite/test/macosx/find-app-in-bundle/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lldb/packages/Python/lldbsuite/test/macosx/find-app-in-bundle/Makefile')
-rw-r--r--lldb/packages/Python/lldbsuite/test/macosx/find-app-in-bundle/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lldb/packages/Python/lldbsuite/test/macosx/find-app-in-bundle/Makefile b/lldb/packages/Python/lldbsuite/test/macosx/find-app-in-bundle/Makefile
index c75a079fe81..18a4934cca3 100644
--- a/lldb/packages/Python/lldbsuite/test/macosx/find-app-in-bundle/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/macosx/find-app-in-bundle/Makefile
@@ -1,3 +1,5 @@
+SRCDIR := $(shell dirname $(realpath $(lastword $(MAKEFILE_LIST))))/
+
CC ?= clang
ifeq "$(ARCH)" ""
@@ -8,9 +10,12 @@ CFLAGS ?= -g -O0 -arch $(ARCH)
all: TestApp.app/Contents/MacOS/TestApp
-TestApp.app/Contents/MacOS/TestApp:
- $(CC) $(CFLAGS) -o TestApp main.c
+TestApp.app/Contents/MacOS/TestApp: $(SRCDIR)/main.c
+ $(CC) $(CFLAGS) -o TestApp $<
+ rm -rf TestApp.app
+ cp -r $(SRCDIR)/TestApp.app .
mv TestApp TestApp.app/Contents/MacOS/TestApp
mv TestApp.dSYM TestApp.app.dSYM
+
clean:
rm -rf TestApp.app/Contents/MacOS/TestApp TestApp.app.dSYM
OpenPOWER on IntegriCloud