summaryrefslogtreecommitdiffstats
path: root/lldb/packages/Python/lldbsuite/test/lang/cpp
diff options
context:
space:
mode:
Diffstat (limited to 'lldb/packages/Python/lldbsuite/test/lang/cpp')
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/auto/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/bool/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint-commands/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint_in_member_func_w_non_primitive_params/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/call-function/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/chained-calls/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/char1632_t/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/char8_t/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/class-template-parameter-pack/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/class_static/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/class_types/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/diamond/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value-same-basename/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/enum_types/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/exceptions/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/extern_c/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/frame-var-anon-unions/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/function-template-parameter-pack/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/function_refs/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/global_operators/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/global_variables/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules-templates/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/incomplete-types/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/inlines/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/limit-debug-info/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/llvm-style/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/member-and-local-vars-with-same-name/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/modules-import/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/namespace/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_conflicts/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/a.mk4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/b.mk4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/nsimport/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/offsetof/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/operator-overload/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/operators/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/overloaded-functions/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/rvalue-references/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/scope/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/signed_types/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/static_members/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/static_methods/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/std-function-step-into-callable/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/stl/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/symbols/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/template-function/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/template/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/this/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/trivial_abi/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/type_lookup/Makefile3
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/unicode-literals/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/unique-types/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/unsigned_types/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/virtual-overload/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/virtual/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/wchar_t/Makefile4
60 files changed, 60 insertions, 168 deletions
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/auto/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/auto/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/auto/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/auto/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/bool/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/bool/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/bool/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/bool/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint-commands/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint-commands/Makefile
index 1d1f38f7fd0..6afea39f81c 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint-commands/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint-commands/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := nested.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint_in_member_func_w_non_primitive_params/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint_in_member_func_w_non_primitive_params/Makefile
index 38d1625c615..dc53622129f 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint_in_member_func_w_non_primitive_params/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/breakpoint_in_member_func_w_non_primitive_params/Makefile
@@ -1,6 +1,4 @@
-LEVEL = ../../../make
-
CXX_SOURCES = main.cpp a.cpp
CFLAGS_EXTRAS = $(MANDATORY_CXXMODULE_BUILD_CFLAGS)
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/call-function/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/call-function/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/call-function/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/call-function/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/chained-calls/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/chained-calls/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/chained-calls/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/chained-calls/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/char1632_t/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/char1632_t/Makefile
index 932046f2696..64fd6effcee 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/char1632_t/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/char1632_t/Makefile
@@ -1,8 +1,6 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
CFLAGS :=-g -O0 -std=c++11
clean: OBJECTS+=$(wildcard main.d.*)
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/char8_t/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/char8_t/Makefile
index 444da5fae9c..c69bf503a34 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/char8_t/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/char8_t/Makefile
@@ -1,6 +1,4 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
CFLAGS_EXTRAS := -std=c++2a -fchar8_t
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/class-template-parameter-pack/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/class-template-parameter-pack/Makefile
index 99bfa7e03b4..3d0b98f13f3 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/class-template-parameter-pack/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/class-template-parameter-pack/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/class_static/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/class_static/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/class_static/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/class_static/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/class_types/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/class_types/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/class_types/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/class_types/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile
index 52a92c0b61a..b5d2d900f90 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile
@@ -1,7 +1,6 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
CXXFLAGS += -std=c++11
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
cleanup:
rm -f Makefile *.d
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/diamond/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/diamond/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/diamond/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/diamond/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value-same-basename/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value-same-basename/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value-same-basename/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value-same-basename/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value/Makefile
index 8770b2343ef..2bba8e757f7 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/dynamic-value/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := pass-to-base.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/enum_types/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/enum_types/Makefile
index 0e0f5d1dad3..ac4b37c7c7b 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/enum_types/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/enum_types/Makefile
@@ -1,10 +1,8 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
CXXFLAGS += -std=c++11
clean: OBJECTS+=$(wildcard main.d.*)
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/exceptions/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/exceptions/Makefile
index a6bd8463ad5..edb53da7b8e 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/exceptions/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/exceptions/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := exceptions.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/extern_c/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/extern_c/Makefile
index 99bfa7e03b4..3d0b98f13f3 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/extern_c/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/extern_c/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/frame-var-anon-unions/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/frame-var-anon-unions/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/frame-var-anon-unions/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/frame-var-anon-unions/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/function-template-parameter-pack/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/function-template-parameter-pack/Makefile
index 99bfa7e03b4..3d0b98f13f3 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/function-template-parameter-pack/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/function-template-parameter-pack/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/function_refs/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/function_refs/Makefile
index 99bfa7e03b4..3d0b98f13f3 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/function_refs/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/function_refs/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/global_operators/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/global_operators/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/global_operators/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/global_operators/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/global_variables/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/global_variables/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/global_variables/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/global_variables/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules-templates/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules-templates/Makefile
index 0497d78fec3..9826dd4af44 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules-templates/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules-templates/Makefile
@@ -1,6 +1,4 @@
-LEVEL = ../../../make
-
CXX_SOURCES = main.cpp
# CFLAGS_EXTRAS += $(MODULE_DEBUG_INFO_FLAGS)
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules/Makefile
index da6f39a7488..4a430eccc70 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/gmodules/Makefile
@@ -1,7 +1,5 @@
-LEVEL = ../../../make
-
PCH_CXX_SOURCE = pch.h
CXX_SOURCES = main.cpp
CFLAGS_EXTRAS += $(MODULE_DEBUG_INFO_FLAGS)
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/incomplete-types/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/incomplete-types/Makefile
index 2ce96e90d2d..769920c2833 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/incomplete-types/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/incomplete-types/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES = main.cpp length.cpp a.cpp
CFLAGS_LIMIT = -c $(CXXFLAGS)
@@ -32,4 +30,4 @@ a.o: a.cpp
clean: OBJECTS += limit nolimit length_limit.o length_nolimit.o length_limit.dwo length_nolimit.dwo
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/inlines/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/inlines/Makefile
index 8f67abdf2b3..055e318e220 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/inlines/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/inlines/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := inlines.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/limit-debug-info/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/limit-debug-info/Makefile
index b9a3d3fe1c8..8e811fdeb67 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/limit-debug-info/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/limit-debug-info/Makefile
@@ -1,7 +1,5 @@
-LEVEL = ../../../make
-
CXX_SOURCES = main.cpp derived.cpp base.cpp
CFLAGS_EXTRAS += $(LIMIT_DEBUG_INFO_FLAGS)
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/llvm-style/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/llvm-style/Makefile
index aae93a20b9c..f78d6a76780 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/llvm-style/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/llvm-style/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules \ No newline at end of file
+include Makefile.rules \ No newline at end of file
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/member-and-local-vars-with-same-name/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/member-and-local-vars-with-same-name/Makefile
index 35eb63f922f..82f96b62609 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/member-and-local-vars-with-same-name/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/member-and-local-vars-with-same-name/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES = main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/modules-import/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/modules-import/Makefile
index 2b8f23bcec7..9e7837a7695 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/modules-import/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/modules-import/Makefile
@@ -1,5 +1,4 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
CFLAGS_EXTRAS = $(MANDATORY_MODULE_BUILD_CFLAGS) -I$(BUILDDIR)/include
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace/Makefile
index 7dd5eb4c11f..638974fafd6 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp ns.cpp ns2.cpp ns3.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_conflicts/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_conflicts/Makefile
index 99bfa7e03b4..3d0b98f13f3 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_conflicts/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_conflicts/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/Makefile
index 9e52bacd5fc..a8ed4b5ecf1 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/Makefile
@@ -1,9 +1,7 @@
-LEVEL := ../../../make
-
LD_EXTRAS := -L. -l$(LIB_PREFIX)a -l$(LIB_PREFIX)b
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
.PHONY:
a.out: lib_a lib_b
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/a.mk b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/a.mk
index e53570873a3..b214267c062 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/a.mk
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/a.mk
@@ -1,7 +1,5 @@
-LEVEL := ../../../make
-
DYLIB_NAME := a
DYLIB_CXX_SOURCES := a.cpp
DYLIB_ONLY := YES
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/b.mk b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/b.mk
index 54a1d8dea5a..7fc442d2ae0 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/b.mk
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/namespace_definitions/b.mk
@@ -1,7 +1,5 @@
-LEVEL := ../../../make
-
DYLIB_NAME := b
DYLIB_CXX_SOURCES := b.cpp
DYLIB_ONLY := YES
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/nsimport/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/nsimport/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/nsimport/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/nsimport/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/offsetof/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/offsetof/Makefile
index 99bfa7e03b4..3d0b98f13f3 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/offsetof/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/offsetof/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/operator-overload/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/operator-overload/Makefile
index bd8116b91c3..80b3ee02c3e 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/operator-overload/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/operator-overload/Makefile
@@ -1,8 +1,6 @@
-LEVEL = ../../../make
-
CXX_SOURCES = a.cpp b.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
a.o: a.cpp
$(CC) $(CFLAGS_NO_DEBUG) -c $< -o $@
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/operators/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/operators/Makefile
index 99bfa7e03b4..3d0b98f13f3 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/operators/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/operators/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/overloaded-functions/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/overloaded-functions/Makefile
index a8d5c4eb026..1185ed0c1e8 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/overloaded-functions/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/overloaded-functions/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp static-a.cpp static-b.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/rvalue-references/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/rvalue-references/Makefile
index 3a1d8a57935..57ee6052ae9 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/rvalue-references/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/rvalue-references/Makefile
@@ -1,7 +1,5 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
CXXFLAGS += -std=c++11
-include $(LEVEL)/Makefile.rules \ No newline at end of file
+include Makefile.rules \ No newline at end of file
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/scope/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/scope/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/scope/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/scope/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/signed_types/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/signed_types/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/signed_types/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/signed_types/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/static_members/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/static_members/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/static_members/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/static_members/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/static_methods/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/static_methods/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/static_methods/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/static_methods/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/std-function-step-into-callable/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/std-function-step-into-callable/Makefile
index a42bb089d15..f96dd95399e 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/std-function-step-into-callable/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/std-function-step-into-callable/Makefile
@@ -1,7 +1,5 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
CXXFLAGS += -std=c++11
USE_LIBCPP := 1
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/stl/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/stl/Makefile
index fe27980afe9..a4b03ae0aab 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/stl/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/stl/Makefile
@@ -1,8 +1,6 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
CFLAGS := -g -O0
clean: OBJECTS+=$(wildcard main.d.*)
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/symbols/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/symbols/Makefile
index 99bfa7e03b4..3d0b98f13f3 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/symbols/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/symbols/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/template-function/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/template-function/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/template-function/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/template-function/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/template/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/template/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/template/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/template/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/this/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/this/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/this/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/this/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/trivial_abi/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/trivial_abi/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/trivial_abi/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/trivial_abi/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/type_lookup/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/type_lookup/Makefile
index 99bfa7e03b4..3d0b98f13f3 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/type_lookup/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/type_lookup/Makefile
@@ -1,3 +1,2 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/unicode-literals/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/unicode-literals/Makefile
index 1476447db35..bf443d855ce 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/unicode-literals/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/unicode-literals/Makefile
@@ -1,8 +1,6 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
CFLAGS := -g -O0 -std=c++11
clean: OBJECTS+=$(wildcard main.d.*)
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/unique-types/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/unique-types/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/unique-types/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/unique-types/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/unsigned_types/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/unsigned_types/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/unsigned_types/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/unsigned_types/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/virtual-overload/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/virtual-overload/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/virtual-overload/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/virtual-overload/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/virtual/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/virtual/Makefile
index 314f1cb2f07..99998b20bcb 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/virtual/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/virtual/Makefile
@@ -1,5 +1,3 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/wchar_t/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/wchar_t/Makefile
index fe27980afe9..a4b03ae0aab 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/wchar_t/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/wchar_t/Makefile
@@ -1,8 +1,6 @@
-LEVEL = ../../../make
-
CXX_SOURCES := main.cpp
CFLAGS := -g -O0
clean: OBJECTS+=$(wildcard main.d.*)
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
OpenPOWER on IntegriCloud