summaryrefslogtreecommitdiffstats
path: root/debuginfo-tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'debuginfo-tests/CMakeLists.txt')
-rw-r--r--debuginfo-tests/CMakeLists.txt36
1 files changed, 0 insertions, 36 deletions
diff --git a/debuginfo-tests/CMakeLists.txt b/debuginfo-tests/CMakeLists.txt
deleted file mode 100644
index 60a467fec85..00000000000
--- a/debuginfo-tests/CMakeLists.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-# Debug Info tests. These tests invoke clang to generate programs with
-# various types of debug info, and then run those programs under a debugger
-# such as GDB or LLDB to verify the results.
-
-set(DEBUGINFO_TESTS_SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR})
-set(DEBUGINFO_TESTS_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR})
-
-set(DEBUGINFO_TEST_DEPS
- clang
- llvm-config
- FileCheck
- count
- not
- )
-
-get_target_property(CLANG_SOURCE_DIR clang SOURCE_DIR)
-
-if (TARGET lld)
- set(DEBUGINFO_TESTS_HAS_LLD 1)
- list(APPEND DEBUGINFO_TEST_DEPS lld)
- get_target_property(LLD_SOURCE_DIR lld SOURCE_DIR)
-endif()
-
-configure_lit_site_cfg(
- ${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.py.in
- ${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg.py
- MAIN_CONFIG
- ${CMAKE_CURRENT_SOURCE_DIR}/lit.cfg.py
- )
-
-add_lit_testsuite(check-debuginfo "Running debug info integration tests"
- ${CMAKE_CURRENT_BINARY_DIR}
- DEPENDS ${DEBUGINFO_TEST_DEPS}
- )
-
-set_target_properties(check-debuginfo PROPERTIES FOLDER "Debug info tests") \ No newline at end of file
OpenPOWER on IntegriCloud