summaryrefslogtreecommitdiffstats
path: root/compiler-rt/lib/interception/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler-rt/lib/interception/tests/CMakeLists.txt')
-rw-r--r--compiler-rt/lib/interception/tests/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/compiler-rt/lib/interception/tests/CMakeLists.txt b/compiler-rt/lib/interception/tests/CMakeLists.txt
index 71e9f9d0805..d77b6763ae0 100644
--- a/compiler-rt/lib/interception/tests/CMakeLists.txt
+++ b/compiler-rt/lib/interception/tests/CMakeLists.txt
@@ -127,7 +127,7 @@ macro(add_interception_tests_for_arch arch)
endmacro()
-if(COMPILER_RT_CAN_EXECUTE_TESTS AND NOT ANDROID)
+if(COMPILER_RT_CAN_EXECUTE_TESTS AND NOT ANDROID AND NOT APPLE)
# We use just-built clang to build interception unittests, so we must
# be sure that produced binaries would work.
if(APPLE)
@@ -143,5 +143,3 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS AND NOT ANDROID)
add_interception_tests_for_arch(${arch})
endforeach()
endif()
-
-
OpenPOWER on IntegriCloud