summaryrefslogtreecommitdiffstats
path: root/clang-tools-extra/clang-include-fixer/tool/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang-tools-extra/clang-include-fixer/tool/CMakeLists.txt')
-rw-r--r--clang-tools-extra/clang-include-fixer/tool/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/clang-tools-extra/clang-include-fixer/tool/CMakeLists.txt b/clang-tools-extra/clang-include-fixer/tool/CMakeLists.txt
new file mode 100644
index 00000000000..207995aa69d
--- /dev/null
+++ b/clang-tools-extra/clang-include-fixer/tool/CMakeLists.txt
@@ -0,0 +1,28 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/..)
+
+add_clang_tool(clang-include-fixer
+ ClangIncludeFixer.cpp
+ )
+
+target_link_libraries(clang-include-fixer
+ PRIVATE
+ clangBasic
+ clangFormat
+ clangFrontend
+ clangIncludeFixer
+ clangRewrite
+ clangSerialization
+ clangTooling
+ clangToolingCore
+ findAllSymbols
+ )
+
+install(TARGETS clang-include-fixer
+ RUNTIME DESTINATION bin)
+
+install(PROGRAMS clang-include-fixer.el
+ DESTINATION share/clang
+ COMPONENT clang-include-fixer)
+install(PROGRAMS clang-include-fixer.py
+ DESTINATION share/clang
+ COMPONENT clang-include-fixer)
OpenPOWER on IntegriCloud