summaryrefslogtreecommitdiffstats
path: root/polly/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Kruse <llvm@meinersbur.de>2018-08-01 00:15:16 +0000
committerMichael Kruse <llvm@meinersbur.de>2018-08-01 00:15:16 +0000
commit23655020a271d83870163905905a13a26cfceb94 (patch)
tree00ca485d7d4f70df2c1723a91020362a9f59c2bb /polly/lib/CMakeLists.txt
parent83c49e8ed407ae60e1d82f389780a4fc5e9b430f (diff)
downloadbcm5719-llvm-23655020a271d83870163905905a13a26cfceb94.tar.gz
bcm5719-llvm-23655020a271d83870163905905a13a26cfceb94.zip
[JSONExporter] Replace bundled Jsoncpp with llvm/Support/JSON.h. NFC.
Differential Revision: https://reviews.llvm.org/D49950 llvm-svn: 338461
Diffstat (limited to 'polly/lib/CMakeLists.txt')
-rw-r--r--polly/lib/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/polly/lib/CMakeLists.txt b/polly/lib/CMakeLists.txt
index 0e81a31295b..954654112c8 100644
--- a/polly/lib/CMakeLists.txt
+++ b/polly/lib/CMakeLists.txt
@@ -52,7 +52,6 @@ add_library(PollyCore OBJECT
Support/ISLTools.cpp
Support/DumpModulePass.cpp
Support/VirtualInstruction.cpp
- ${POLLY_JSON_FILES}
Transform/Canonicalization.cpp
Transform/CodePreparation.cpp
Transform/DeadCodeElimination.cpp
@@ -77,7 +76,6 @@ set_target_properties(PollyCore PROPERTIES FOLDER "Polly")
add_polly_library(Polly $<TARGET_OBJECTS:PollyCore>)
target_link_libraries(Polly PUBLIC
${ISL_TARGET}
- ${JSONCPP_LIBRARIES}
)
# Additional dependencies for Polly-ACC.
@@ -145,7 +143,7 @@ else ()
# hosts. This is not the case for bugpoint. Use LLVM_POLLY_LINK_INTO_TOOLS=ON
# instead which will automatically resolve the additional dependencies by
# Polly.
- target_link_libraries(LLVMPolly PUBLIC ${ISL_TARGET} ${JSONCPP_LIBRARIES})
+ target_link_libraries(LLVMPolly PUBLIC ${ISL_TARGET})
if (GPU_CODEGEN)
target_link_libraries(LLVMPolly PUBLIC PollyPPCG)
endif ()
OpenPOWER on IntegriCloud