summaryrefslogtreecommitdiffstats
path: root/polly/CMakeLists.txt
diff options
context:
space:
mode:
authorHongbin Zheng <etherzhhb@gmail.com>2012-03-16 14:34:27 +0000
committerHongbin Zheng <etherzhhb@gmail.com>2012-03-16 14:34:27 +0000
commitc507b1e262c8e753bfe1d013fd01d14ab5964f55 (patch)
tree69ec4ddd03e3e46bc7d53acb5a5e7044baf06555 /polly/CMakeLists.txt
parentc7584ff270a67449cef97fe544b5e590eedb0802 (diff)
downloadbcm5719-llvm-c507b1e262c8e753bfe1d013fd01d14ab5964f55.tar.gz
bcm5719-llvm-c507b1e262c8e753bfe1d013fd01d14ab5964f55.zip
Off-tree build support: Also check the existence of the "not" utility.
llvm-svn: 152925
Diffstat (limited to 'polly/CMakeLists.txt')
-rw-r--r--polly/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/polly/CMakeLists.txt b/polly/CMakeLists.txt
index 8b80d551b9f..97f254383b8 100644
--- a/polly/CMakeLists.txt
+++ b/polly/CMakeLists.txt
@@ -10,10 +10,13 @@ if (NOT DEFINED LLVM_MAIN_SRC_DIR)
message(FATAL_ERROR "LLVM_INSTALL_ROOT (${LLVM_INSTALL_ROOT}) is not a valid LLVM installation.")
endif(NOT EXISTS ${LLVM_INSTALL_ROOT}/include/llvm)
#FileCheck is not install by default, warn the user to Copy FileCheck
- if( NOT EXISTS ${LLVM_INSTALL_ROOT}/bin/FileCheck )
- message(WARNING "FileCheck is requred by running regress tests, but not been installed! "
- "Please copy it to ${LLVM_INSTALL_ROOT}/bin.")
- endif(NOT EXISTS ${LLVM_INSTALL_ROOT}/bin/FileCheck)
+ if( NOT EXISTS ${LLVM_INSTALL_ROOT}/bin/FileCheck
+ OR NOT EXISTS ${LLVM_INSTALL_ROOT}/bin/not)
+ message(WARNING "FileCheck or not are requred by running regress tests, "
+ "but they are not installed! Please copy it to "
+ "${LLVM_INSTALL_ROOT}/bin.")
+ endif(NOT EXISTS ${LLVM_INSTALL_ROOT}/bin/FileCheck
+ OR NOT EXISTS ${LLVM_INSTALL_ROOT}/bin/not)
# Add the llvm header path.
include_directories(${LLVM_INSTALL_ROOT}/include/)
OpenPOWER on IntegriCloud