summaryrefslogtreecommitdiffstats
path: root/polly/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Grosser <tobias@grosser.es>2014-04-11 09:47:45 +0000
committerTobias Grosser <tobias@grosser.es>2014-04-11 09:47:45 +0000
commitb24cf90645282a169d814c0813de27f5bdfe46a4 (patch)
tree6a298fbb8e3b5a2754e78c8774b4569984968b61 /polly/CMakeLists.txt
parentec959d5f46b6d54be51000cf1eb7707b9b9488a5 (diff)
downloadbcm5719-llvm-b24cf90645282a169d814c0813de27f5bdfe46a4.tar.gz
bcm5719-llvm-b24cf90645282a169d814c0813de27f5bdfe46a4.zip
Remove OpenScop
We only supported a very old version of OpenScop that was entirely different to what OpenScop is today. To not confuse people, we remove this old and unusable support. If anyone is interested to add OpenScop support back in, the relevant patches are available in version control. llvm-svn: 206026
Diffstat (limited to 'polly/CMakeLists.txt')
-rw-r--r--polly/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/polly/CMakeLists.txt b/polly/CMakeLists.txt
index a9e4732cbb9..7958274dd6c 100644
--- a/polly/CMakeLists.txt
+++ b/polly/CMakeLists.txt
@@ -111,14 +111,6 @@ if (POLLY_ENABLE_GPGPU_CODEGEN)
set(GPU_CODEGEN TRUE)
endif(POLLY_ENABLE_GPGPU_CODEGEN)
-option(POLLY_ENABLE_OPENSCOP "Enable Openscop library for scop import/export" ON)
-if (POLLY_ENABLE_OPENSCOP)
- FIND_PACKAGE(OpenScop)
- if(OPENSCOP_FOUND)
- set(POLLY_LINK_LIBS ${POLLY_LINK_LIBS} ${OPENSCOP_LIBRARY})
- endif(OPENSCOP_FOUND)
-endif(POLLY_ENABLE_OPENSCOP)
-
option(POLLY_ENABLE_SCOPLIB "Enable SCoPLib library for scop import/export" ON)
if (POLLY_ENABLE_SCOPLIB)
FIND_PACKAGE(SCoPLib)
@@ -143,10 +135,6 @@ if (CUDALIB_FOUND)
INCLUDE_DIRECTORIES( ${CUDALIB_INCLUDE_DIR} )
endif(CUDALIB_FOUND)
-# Support OpenScop export/import if the library is available.
-if (OPENSCOP_FOUND)
- INCLUDE_DIRECTORIES( ${OPENSCOP_INCLUDE_DIR} )
-endif(OPENSCOP_FOUND)
if (SCOPLIB_FOUND)
INCLUDE_DIRECTORIES( ${SCOPLIB_INCLUDE_DIR} )
endif(SCOPLIB_FOUND)
OpenPOWER on IntegriCloud