summaryrefslogtreecommitdiffstats
path: root/polly/CMakeLists.txt
diff options
context:
space:
mode:
authorJohannes Doerfert <doerfert@cs.uni-saarland.de>2014-08-18 00:40:13 +0000
committerJohannes Doerfert <doerfert@cs.uni-saarland.de>2014-08-18 00:40:13 +0000
commit9e7b17b0d484861350c4b818697b81e1bc8ac96a (patch)
treefda45bea5b780281569a3c26e7f77b03e418dcc9 /polly/CMakeLists.txt
parent6230691c9186e95cd19dff07074a54fb70719957 (diff)
downloadbcm5719-llvm-9e7b17b0d484861350c4b818697b81e1bc8ac96a.tar.gz
bcm5719-llvm-9e7b17b0d484861350c4b818697b81e1bc8ac96a.zip
Added arcanist linters and cleaned errors and warnings
Arcanist (arc) will now always run linters before uploading any new commit to Phabricator. All errors/warnings (or their absence) will be shown in the web interface together with a explanation by the commiter (arcanist will ask the commiter if the build was not clean). The linters include: - clang-format - spelling check - permissions check (aka. chmod) - filename check - merge conflict marker check Note, that their scope is sometimes limited (see .arclint for details). This commit also fixes all errors and warnings these linters reported, namely: - spelling mistakes and typos - executable permissions for various text files Differential Revision: http://reviews.llvm.org/D4916 llvm-svn: 215871
Diffstat (limited to 'polly/CMakeLists.txt')
-rw-r--r--polly/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/polly/CMakeLists.txt b/polly/CMakeLists.txt
index c56f5e9027a..7d6e8a91ccc 100644
--- a/polly/CMakeLists.txt
+++ b/polly/CMakeLists.txt
@@ -12,7 +12,7 @@ if (NOT DEFINED LLVM_MAIN_SRC_DIR)
#FileCheck is not install by default, warn the user to Copy FileCheck
if( NOT EXISTS ${LLVM_INSTALL_ROOT}/bin/FileCheck
OR NOT EXISTS ${LLVM_INSTALL_ROOT}/bin/not)
- message(WARNING "FileCheck or not are requred by running regress tests, "
+ message(WARNING "FileCheck or not are required by running regress tests, "
"but they are not installed! Please copy it to "
"${LLVM_INSTALL_ROOT}/bin.")
endif(NOT EXISTS ${LLVM_INSTALL_ROOT}/bin/FileCheck
OpenPOWER on IntegriCloud