summaryrefslogtreecommitdiffstats
path: root/openmp/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Hahnfeld <Hahnfeld@itc.rwth-aachen.de>2016-02-05 07:00:13 +0000
committerJonas Hahnfeld <Hahnfeld@itc.rwth-aachen.de>2016-02-05 07:00:13 +0000
commit66594990b1cd55a9cc265cd694f92a03da9543a3 (patch)
tree76002cc9a9e92816464a320563a3772cf30ef68a /openmp/CMakeLists.txt
parent084e363517fc2248412f227862cdabd2f439e83d (diff)
downloadbcm5719-llvm-66594990b1cd55a9cc265cd694f92a03da9543a3.tar.gz
bcm5719-llvm-66594990b1cd55a9cc265cd694f92a03da9543a3.zip
[CMake] Introduce OPENMP_LLVM_TOOLS_DIR
This will be used in a later patch to find additional LLVM tools for tests and enables reusability for libomptarget that is currently under review. Differential Revision: http://reviews.llvm.org/D16713 llvm-svn: 259876
Diffstat (limited to 'openmp/CMakeLists.txt')
-rw-r--r--openmp/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/openmp/CMakeLists.txt b/openmp/CMakeLists.txt
index 7011187b93c..3d60633b33b 100644
--- a/openmp/CMakeLists.txt
+++ b/openmp/CMakeLists.txt
@@ -1,2 +1,5 @@
cmake_minimum_required(VERSION 2.8 FATAL_ERROR)
+
+set(OPENMP_LLVM_TOOLS_DIR "" CACHE PATH "Path to LLVM tools for testing")
+
add_subdirectory(runtime)
OpenPOWER on IntegriCloud