summaryrefslogtreecommitdiffstats
path: root/llvm/lib/MC/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Cooper <peter_cooper@apple.com>2015-05-15 21:29:43 +0000
committerPete Cooper <peter_cooper@apple.com>2015-05-15 21:29:43 +0000
commit80735a2d8e9c43be438bd1d647cd0a02d394aa84 (patch)
tree19c504d63bf9fca16009f40cf10678497f1893ee /llvm/lib/MC/CMakeLists.txt
parent67d49488a7f88173e931da7b123f8636f062ef64 (diff)
downloadbcm5719-llvm-80735a2d8e9c43be438bd1d647cd0a02d394aa84.tar.gz
bcm5719-llvm-80735a2d8e9c43be438bd1d647cd0a02d394aa84.zip
Move some methods to a new MCInstrDesc.cpp file to allow includes to be trimmed. NFC.
MCInstrDesc.h includes things like MCInst.h which i can now remove after this. That will be a future commit. Reviewed by Jim Grosbach. llvm-svn: 237478
Diffstat (limited to 'llvm/lib/MC/CMakeLists.txt')
-rw-r--r--llvm/lib/MC/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/llvm/lib/MC/CMakeLists.txt b/llvm/lib/MC/CMakeLists.txt
index ddddd49d90e..3cee0c43494 100644
--- a/llvm/lib/MC/CMakeLists.txt
+++ b/llvm/lib/MC/CMakeLists.txt
@@ -19,6 +19,7 @@ add_llvm_library(LLVMMC
MCInst.cpp
MCInstPrinter.cpp
MCInstrAnalysis.cpp
+ MCInstrDesc.cpp
MCLabel.cpp
MCLinkerOptimizationHint.cpp
MCMachOStreamer.cpp
OpenPOWER on IntegriCloud