summaryrefslogtreecommitdiffstats
path: root/llvm/lib/MC/CMakeLists.txt
diff options
context:
space:
mode:
authorBruno Cardoso Lopes <bruno.cardoso@gmail.com>2009-08-13 05:07:35 +0000
committerBruno Cardoso Lopes <bruno.cardoso@gmail.com>2009-08-13 05:07:35 +0000
commit607cd3b63af5af83283a6f242d721c6997e18fca (patch)
tree68ff3a8d58a70de07d0ea4c8a28991a04176d094 /llvm/lib/MC/CMakeLists.txt
parent5c2764b3e9071cae6300f26fe0e4de8fb904d2c3 (diff)
downloadbcm5719-llvm-607cd3b63af5af83283a6f242d721c6997e18fca.tar.gz
bcm5719-llvm-607cd3b63af5af83283a6f242d721c6997e18fca.zip
Change MCSectionELF to represent a section semantically instead of
syntactically as a string, very similiar to what Chris did with MachO. The parsing support and validation is not introduced yet. llvm-svn: 78890
Diffstat (limited to 'llvm/lib/MC/CMakeLists.txt')
-rw-r--r--llvm/lib/MC/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/llvm/lib/MC/CMakeLists.txt b/llvm/lib/MC/CMakeLists.txt
index e3cc536444e..ec76320ad34 100644
--- a/llvm/lib/MC/CMakeLists.txt
+++ b/llvm/lib/MC/CMakeLists.txt
@@ -4,6 +4,7 @@ add_llvm_library(LLVMMC
MCAsmStreamer.cpp
MCContext.cpp
MCSection.cpp
+ MCSectionELF.cpp
MCSectionMachO.cpp
MCStreamer.cpp
TargetAsmParser.cpp
OpenPOWER on IntegriCloud