summaryrefslogtreecommitdiffstats
path: root/llvm/CMakeLists.txt
diff options
context:
space:
mode:
authorDon Hinton <hintonda@gmail.com>2018-01-25 04:55:18 +0000
committerDon Hinton <hintonda@gmail.com>2018-01-25 04:55:18 +0000
commit32ff6599a81d930f035fb6501be97243c91180a7 (patch)
tree9bf2a507c556a3bba5e7f54eddd4677a8f0673fd /llvm/CMakeLists.txt
parent066e73762df8c5d8a6d8b4fb919b71cc89f28dc8 (diff)
downloadbcm5719-llvm-32ff6599a81d930f035fb6501be97243c91180a7.tar.gz
bcm5719-llvm-32ff6599a81d930f035fb6501be97243c91180a7.zip
[cmake] Set cmake policy CMP0068 to suppress warnings on OSX
Set cmake policy CMP0068=NEW, if available, and set "CMAKE_BUILD_WITH_INSTALL_NAME_DIR=On" globally to maintain current behavior. This is needed to suppress warnings on OSX starting with cmake version 3.9.6. Differential Revision: https://reviews.llvm.org/D42463 llvm-svn: 323404
Diffstat (limited to 'llvm/CMakeLists.txt')
-rw-r--r--llvm/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/llvm/CMakeLists.txt b/llvm/CMakeLists.txt
index 198dbff3144..12c47b2cd6a 100644
--- a/llvm/CMakeLists.txt
+++ b/llvm/CMakeLists.txt
@@ -17,6 +17,11 @@ cmake_policy(SET CMP0056 NEW)
cmake_policy(SET CMP0057 NEW)
+if(POLICY CMP0068)
+ cmake_policy(SET CMP0068 NEW)
+ set(CMAKE_BUILD_WITH_INSTALL_NAME_DIR ON)
+endif()
+
if(NOT DEFINED LLVM_VERSION_MAJOR)
set(LLVM_VERSION_MAJOR 7)
endif()
OpenPOWER on IntegriCloud