summaryrefslogtreecommitdiffstats
path: root/lldb/tools/lldb-vscode/CMakeLists.txt
diff options
context:
space:
mode:
authorGreg Clayton <gclayton@apple.com>2018-08-16 17:59:38 +0000
committerGreg Clayton <gclayton@apple.com>2018-08-16 17:59:38 +0000
commit2f5cf8511a3f0ad97db2acf51c6c9ea0ddc9da92 (patch)
tree43ad29bf650e6570830784ff0aa4cfc2ccab5807 /lldb/tools/lldb-vscode/CMakeLists.txt
parentcecc9f5828615c07192a31c7ba8cfda5d26f3cfc (diff)
downloadbcm5719-llvm-2f5cf8511a3f0ad97db2acf51c6c9ea0ddc9da92.tar.gz
bcm5719-llvm-2f5cf8511a3f0ad97db2acf51c6c9ea0ddc9da92.zip
Add a new tool named "lldb-vscode" that implements the Visual Studio Code Debug Adaptor Protocol
This patch adds a new lldb-vscode tool that speaks the Microsoft Visual Studio Code debug adaptor protocol. It has full unit tests that test all packets. This tool can be easily packaged up into a native extension and used with Visual Studio Code, and it can also be used by Nuclide Differential Revision: https://reviews.llvm.org/D50365 llvm-svn: 339911
Diffstat (limited to 'lldb/tools/lldb-vscode/CMakeLists.txt')
-rw-r--r--lldb/tools/lldb-vscode/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/lldb/tools/lldb-vscode/CMakeLists.txt b/lldb/tools/lldb-vscode/CMakeLists.txt
new file mode 100644
index 00000000000..f1570089a84
--- /dev/null
+++ b/lldb/tools/lldb-vscode/CMakeLists.txt
@@ -0,0 +1,30 @@
+if ( CMAKE_SYSTEM_NAME MATCHES "Windows" OR CMAKE_SYSTEM_NAME MATCHES "NetBSD" )
+ add_definitions( -DIMPORT_LIBLLDB )
+ list(APPEND extra_libs lldbHost)
+endif ()
+
+if (HAVE_LIBPTHREAD)
+ list(APPEND extra_libs pthread)
+endif ()
+
+# We need to include the llvm components we depend on manually, as liblldb does
+# not re-export those.
+set(LLVM_LINK_COMPONENTS Support)
+add_lldb_tool(lldb-vscode
+ lldb-vscode.cpp
+ BreakpointBase.cpp
+ ExceptionBreakpoint.cpp
+ FunctionBreakpoint.cpp
+ JSONUtils.cpp
+ LLDBUtils.cpp
+ SourceBreakpoint.cpp
+ VSCode.cpp
+
+ LINK_LIBS
+ liblldb
+ ${host_lib}
+ ${extra_libs}
+
+ LINK_COMPONENTS
+ Support
+ )
OpenPOWER on IntegriCloud