summaryrefslogtreecommitdiffstats
path: root/lldb/tools/debugserver/source/MacOSX/DarwinLog/CMakeLists.txt
diff options
context:
space:
mode:
authorTodd Fiala <todd.fiala@gmail.com>2016-08-19 04:21:48 +0000
committerTodd Fiala <todd.fiala@gmail.com>2016-08-19 04:21:48 +0000
commit759300192abe8e38e8a40ab95934ba602a78c252 (patch)
treed284c51cf10c23d3023ab8e1308e26ad1ee218a7 /lldb/tools/debugserver/source/MacOSX/DarwinLog/CMakeLists.txt
parente2ca3b65fcba7c4c5dbd10c1e8925177b7718806 (diff)
downloadbcm5719-llvm-759300192abe8e38e8a40ab95934ba602a78c252.tar.gz
bcm5719-llvm-759300192abe8e38e8a40ab95934ba602a78c252.zip
Add StructuredData plugin type; showcase with new DarwinLog feature
Take 2, with missing cmake line fixed. Build tested on Ubuntu 14.04 with clang-3.6. See docs/structured_data/StructuredDataPlugins.md for details. differential review: https://reviews.llvm.org/D22976 reviewers: clayborg, jingham llvm-svn: 279202
Diffstat (limited to 'lldb/tools/debugserver/source/MacOSX/DarwinLog/CMakeLists.txt')
-rw-r--r--lldb/tools/debugserver/source/MacOSX/DarwinLog/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/lldb/tools/debugserver/source/MacOSX/DarwinLog/CMakeLists.txt b/lldb/tools/debugserver/source/MacOSX/DarwinLog/CMakeLists.txt
new file mode 100644
index 00000000000..47e7362f0d5
--- /dev/null
+++ b/lldb/tools/debugserver/source/MacOSX/DarwinLog/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Due to sources including headers like:
+# #include "MacOSX/i386/DNBArchImplI386.h"
+# we must include the grandparent directory...
+include_directories(${LLDB_SOURCE_DIR}/tools/debugserver/source)
+
+add_library(lldbDebugserverMacOSX_DarwinLog
+ ActivityStore.cpp
+ DarwinLogCollector.cpp
+ LogFilter.cpp
+ LogFilterChain.cpp
+ LogFilterExactMatch.cpp
+ LogFilterRegex.cpp
+ LogMessage.cpp
+ LogMessageOsLog.cpp
+ )
OpenPOWER on IntegriCloud