summaryrefslogtreecommitdiffstats
path: root/lldb/test/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2016-05-23 17:32:04 +0000
committerZachary Turner <zturner@google.com>2016-05-23 17:32:04 +0000
commitfa7f9482376646e867778a26f57e54cdbcef7e51 (patch)
treeccd8e85149722129ad1cfae9b30068cc758b51ca /lldb/test/CMakeLists.txt
parent4a3e285ec3b39fd49f2606417080d09108e84adf (diff)
downloadbcm5719-llvm-fa7f9482376646e867778a26f57e54cdbcef7e51.tar.gz
bcm5719-llvm-fa7f9482376646e867778a26f57e54cdbcef7e51.zip
Always rerun all tests on Windows.
There is flakiness somewhere in the core infrastructure on Windows, so to get the buildbot reliably green we need to mark all tests as flaky. llvm-svn: 270460
Diffstat (limited to 'lldb/test/CMakeLists.txt')
-rw-r--r--lldb/test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lldb/test/CMakeLists.txt b/lldb/test/CMakeLists.txt
index 1fdb495f4f5..5c34932b1f4 100644
--- a/lldb/test/CMakeLists.txt
+++ b/lldb/test/CMakeLists.txt
@@ -44,6 +44,9 @@ set(LLDB_TEST_COMMON_ARGS
)
if ( CMAKE_SYSTEM_NAME MATCHES "Windows" )
+ # All tests are currently flaky on Windows, so rerun them all once when they fail.
+ set(LLDB_TEST_COMMON_ARGS ${LLDB_TEST_COMMON_ARGS} --rerun-all-issues)
+
set(LLDB_TEST_DEBUG_TEST_CRASHES
0
CACHE BOOL "(Windows only) Enables debugging of tests in the test suite by showing the crash dialog when lldb crashes")
OpenPOWER on IntegriCloud