summaryrefslogtreecommitdiffstats
path: root/lldb/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Devlieghere <jonas@devlieghere.com>2018-05-29 12:30:27 +0000
committerJonas Devlieghere <jonas@devlieghere.com>2018-05-29 12:30:27 +0000
commitf6c870a794e3e09660ee86e5b1eb0b8a17f28c6d (patch)
treeb36cc26fb9b0c344d5dc309fc4a7c010f7ecc54b /lldb/test/CMakeLists.txt
parent5a267ed889071dcf07e123a9841eeb7de0c089fb (diff)
downloadbcm5719-llvm-f6c870a794e3e09660ee86e5b1eb0b8a17f28c6d.tar.gz
bcm5719-llvm-f6c870a794e3e09660ee86e5b1eb0b8a17f28c6d.zip
[test] Fix --framework argument passed to dotest.
The framework argument was broken when I removed the generator expressions upstream. I replaced $<TARGET_FILE_DIR:liblldb> with ${LLVM_LIBRARY_OUTPUT_INTDIR}) which is not correct. rdar://40534649 llvm-svn: 333412
Diffstat (limited to 'lldb/test/CMakeLists.txt')
-rw-r--r--lldb/test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lldb/test/CMakeLists.txt b/lldb/test/CMakeLists.txt
index 54976edb383..463c147ff6c 100644
--- a/lldb/test/CMakeLists.txt
+++ b/lldb/test/CMakeLists.txt
@@ -78,7 +78,7 @@ if(LLDB_CODESIGN_IDENTITY)
endif()
if(LLDB_BUILD_FRAMEWORK)
- list(APPEND LLDB_TEST_COMMON_ARGS --framework ${LLVM_LIBRARY_OUTPUT_INTDIR})
+ list(APPEND LLDB_TEST_COMMON_ARGS --framework ${LLDB_FRAMEWORK_DIR}/LLDB.framework)
endif()
if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "Windows|Darwin")
OpenPOWER on IntegriCloud