summaryrefslogtreecommitdiffstats
path: root/lldb/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVedant Kumar <vsk@apple.com>2018-03-08 19:46:39 +0000
committerVedant Kumar <vsk@apple.com>2018-03-08 19:46:39 +0000
commit45ae11cd80ab83d11c6310c954b0537c2d863a91 (patch)
treec15cd16af1e9f8dacc35913bcc272a72af6db8be /lldb/test/CMakeLists.txt
parentc9a1a6e964f88d4ffc0de91ba2cb5d3232233844 (diff)
downloadbcm5719-llvm-45ae11cd80ab83d11c6310c954b0537c2d863a91.tar.gz
bcm5719-llvm-45ae11cd80ab83d11c6310c954b0537c2d863a91.zip
[test] Skip a test when using an out-of-tree debugserver
The test "test_fp_special_purpose_register_read" in TestRegisters.py fails on Darwin machines configured to use an out-of-tree debugserver. The error message is: 'register read ftag' returns expected result, got 'ftag = 0x80'. This indicates that the debugserver in use is too old. This commit introduces a decorator which can be used to skip tests which rely on having a just-built debugserver. This resolves the issue: $ ./bin/llvm-dotest -p TestRegisters.py -v 1 out of 617 test suites processed - TestRegisters.py Test Methods: 7 Success: 6 Skip: 1 ... llvm-svn: 327052
Diffstat (limited to 'lldb/test/CMakeLists.txt')
-rw-r--r--lldb/test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/lldb/test/CMakeLists.txt b/lldb/test/CMakeLists.txt
index 38a50a9808c..04758c6261c 100644
--- a/lldb/test/CMakeLists.txt
+++ b/lldb/test/CMakeLists.txt
@@ -113,6 +113,10 @@ if(CMAKE_HOST_APPLE)
list(APPEND LLDB_TEST_COMMON_ARGS --server ${DEBUGSERVER_PATH})
endif()
+if(SKIP_DEBUGSERVER)
+ list(APPEND LLDB_TEST_COMMON_ARGS --out-of-tree-debugserver)
+endif()
+
set(LLDB_DOTEST_ARGS ${LLDB_TEST_COMMON_ARGS};${LLDB_TEST_USER_ARGS})
add_python_test_target(check-lldb-single
OpenPOWER on IntegriCloud