summaryrefslogtreecommitdiffstats
path: root/lldb/packages/Python
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2020-01-01 14:19:41 -0800
committerSaleem Abdulrasool <compnerd@compnerd.org>2020-01-01 14:22:49 -0800
commitfb170fd652bf2fcc4c2cd54aaf384591d8df266b (patch)
tree54aa9e4aa216ae61246a8ac8c275cf578745885d /lldb/packages/Python
parent8dd9a1361958f0cc53d100124e158cbe691c4628 (diff)
downloadbcm5719-llvm-fb170fd652bf2fcc4c2cd54aaf384591d8df266b.tar.gz
bcm5719-llvm-fb170fd652bf2fcc4c2cd54aaf384591d8df266b.zip
tests: XFAIL/UNSUPPORTED tests on Windows
Now that we are building the python bindings on Windows once more, the extended testsuite is running. Mark a few failing tests and skip a few tests which hang. This should at least bring the bot back to green without reverting the Python changes which are an improvement for the build system and enable another ~35% of the test suite which was previously disabled.
Diffstat (limited to 'lldb/packages/Python')
-rw-r--r--lldb/packages/Python/lldbsuite/test/commands/settings/TestSettings.py3
-rw-r--r--lldb/packages/Python/lldbsuite/test/functionalities/breakpoint/breakpoint_command/TestBreakpointCommand.py1
-rw-r--r--lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile9
-rw-r--r--lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/TestDeadStrip.py1
-rw-r--r--lldb/packages/Python/lldbsuite/test/source-manager/TestSourceManager.py2
5 files changed, 12 insertions, 4 deletions
diff --git a/lldb/packages/Python/lldbsuite/test/commands/settings/TestSettings.py b/lldb/packages/Python/lldbsuite/test/commands/settings/TestSettings.py
index 3b9f64707bb..1130821bac0 100644
--- a/lldb/packages/Python/lldbsuite/test/commands/settings/TestSettings.py
+++ b/lldb/packages/Python/lldbsuite/test/commands/settings/TestSettings.py
@@ -58,6 +58,7 @@ class SettingsCommandTestCase(TestBase):
'[3]: "b"',
'[4]: "c"'])
+ @expectedFailureAll(oslist=["windows"], bugnumber="llvm.org/pr44430")
def test_replace_target_run_args(self):
"""Test that 'replace target.run-args' works."""
# Set the run-args and then replace the index-0 element.
@@ -106,6 +107,7 @@ class SettingsCommandTestCase(TestBase):
substrs=["term-width (int) = 70"])
# rdar://problem/10712130
+ @skipIf(oslist=["windows"], bugnumber="llvm.org/pr44431")
def test_set_frame_format(self):
"""Test that 'set frame-format' with a backtick char in the format string works as well as fullpath."""
self.build()
@@ -356,6 +358,7 @@ class SettingsCommandTestCase(TestBase):
'thread-format (format-string) = "abc def "')
self.runCmd('settings clear thread-format')
+ @expectedFailureAll(oslist=["windows"], bugnumber="llvm.org/pr44430")
def test_settings_with_trailing_whitespace(self):
# boolean
diff --git a/lldb/packages/Python/lldbsuite/test/functionalities/breakpoint/breakpoint_command/TestBreakpointCommand.py b/lldb/packages/Python/lldbsuite/test/functionalities/breakpoint/breakpoint_command/TestBreakpointCommand.py
index 6f190ea4fbc..77db8f745d7 100644
--- a/lldb/packages/Python/lldbsuite/test/functionalities/breakpoint/breakpoint_command/TestBreakpointCommand.py
+++ b/lldb/packages/Python/lldbsuite/test/functionalities/breakpoint/breakpoint_command/TestBreakpointCommand.py
@@ -22,6 +22,7 @@ class BreakpointCommandTestCase(TestBase):
self.build()
self.breakpoint_command_sequence()
+ @skipIf(oslist=["windows"], bugnumber="llvm.org/pr44431")
def test_script_parameters(self):
"""Test a sequence of breakpoint command add, list, and delete."""
self.build()
diff --git a/lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile b/lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile
index ea15ec84d68..3e7e139ddd6 100644
--- a/lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile
@@ -6,12 +6,13 @@ endif
ifeq "$(OS)" "Darwin"
LD_EXTRAS = -Xlinker -dead_strip
-else ifeq "$(OS)" "Windows_NT"
- CFLAGS_EXTRAS += /Gw /Gy
- LD_EXTRAS = -Xlinker /OPT:REF
else
CFLAGS_EXTRAS += -fdata-sections -ffunction-sections
- LD_EXTRAS = -Wl,--gc-sections
+ ifeq "$(OS)" "Windows_NT"
+ LD_EXTRAS = -Xlinker /OPT:REF
+ else
+ LD_EXTRAS = -Wl,--gc-sections
+ endif
endif
MAKE_DSYM := NO
diff --git a/lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/TestDeadStrip.py b/lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/TestDeadStrip.py
index cb610697807..bc1f3f8003f 100644
--- a/lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/TestDeadStrip.py
+++ b/lldb/packages/Python/lldbsuite/test/functionalities/dead-strip/TestDeadStrip.py
@@ -14,6 +14,7 @@ class DeadStripTestCase(TestBase):
mydir = TestBase.compute_mydir(__file__)
+ @expectedFailureAll(oslist=["windows"], bugnumber="llvm.org/pr44429")
def test(self):
"""Test breakpoint works correctly with dead-code stripping."""
self.build()
diff --git a/lldb/packages/Python/lldbsuite/test/source-manager/TestSourceManager.py b/lldb/packages/Python/lldbsuite/test/source-manager/TestSourceManager.py
index 6831e998369..f91d0760277 100644
--- a/lldb/packages/Python/lldbsuite/test/source-manager/TestSourceManager.py
+++ b/lldb/packages/Python/lldbsuite/test/source-manager/TestSourceManager.py
@@ -171,6 +171,7 @@ class SourceManagerTestCase(TestBase):
self.expect("source list -n main", SOURCE_DISPLAYED_CORRECTLY,
substrs=['Hello world'])
+ @skipIf(oslist=["windows"], bugnumber="llvm.org/pr44431")
def test_modify_source_file_while_debugging(self):
"""Modify a source file while debugging the executable."""
self.build()
@@ -236,6 +237,7 @@ class SourceManagerTestCase(TestBase):
SOURCE_DISPLAYED_CORRECTLY,
substrs=['Hello lldb'])
+ @expectedFailureAll(oslist=["windows"], bugnumber="llvm.org/pr44432")
def test_set_breakpoint_with_absolute_path(self):
self.build()
hidden = self.getBuildArtifact("hidden")
OpenPOWER on IntegriCloud