summaryrefslogtreecommitdiffstats
path: root/lldb/packages/Python/lldbsuite/test/settings
diff options
context:
space:
mode:
authorAdrian Prantl <aprantl@apple.com>2018-01-30 18:29:16 +0000
committerAdrian Prantl <aprantl@apple.com>2018-01-30 18:29:16 +0000
commit5ec76fe720e43a9196d3437e1ff448668bf7db6d (patch)
tree49d569898f53e6887e7167b4470b5e672ddf1541 /lldb/packages/Python/lldbsuite/test/settings
parent1d8e5ea2500728cfc751ce055dd75e5084584e9c (diff)
downloadbcm5719-llvm-5ec76fe720e43a9196d3437e1ff448668bf7db6d.tar.gz
bcm5719-llvm-5ec76fe720e43a9196d3437e1ff448668bf7db6d.zip
Compile the LLDB tests out-of-tree.
This patch is the result of a discussion on lldb-dev, see http://lists.llvm.org/pipermail/lldb-dev/2018-January/013111.html for background. For each test (should be eventually: each test configuration) a separate build directory is created and we execute make VPATH=$srcdir/path/to/test -C $builddir/path/to/test -f $srcdir/path/to/test/Makefile -I $srcdir/path/to/test In order to make this work all LLDB tests need to be updated to find the executable in the test build directory, since CWD still points at the test's source directory, which is a requirement for unittest2. Although we have done extensive testing, I'm expecting that this first attempt will break a few bots. Please DO NOT HESITATE TO REVERT this patch in order to get the bots green again. We will likely have to iterate on this some more. Differential Revision: https://reviews.llvm.org/D42281 llvm-svn: 323803
Diffstat (limited to 'lldb/packages/Python/lldbsuite/test/settings')
-rw-r--r--lldb/packages/Python/lldbsuite/test/settings/TestSettings.py6
-rw-r--r--lldb/packages/Python/lldbsuite/test/settings/quoting/TestQuoting.py18
-rw-r--r--lldb/packages/Python/lldbsuite/test/settings/quoting/main.c4
3 files changed, 17 insertions, 11 deletions
diff --git a/lldb/packages/Python/lldbsuite/test/settings/TestSettings.py b/lldb/packages/Python/lldbsuite/test/settings/TestSettings.py
index 717c0744b1b..8d68ff865d1 100644
--- a/lldb/packages/Python/lldbsuite/test/settings/TestSettings.py
+++ b/lldb/packages/Python/lldbsuite/test/settings/TestSettings.py
@@ -155,7 +155,7 @@ class SettingsCommandTestCase(TestBase):
self.runCmd("breakpoint set -n main")
self.runCmd("run")
self.expect("thread backtrace",
- substrs=["`main", os.getcwd()])
+ substrs=["`main", self.getSourceDir()])
def test_set_auto_confirm(self):
"""Test that after 'set auto-confirm true', manual confirmation should not kick in."""
@@ -421,8 +421,8 @@ class SettingsCommandTestCase(TestBase):
startstr='target.arg0 (string) = "cde"')
self.runCmd("settings clear target.arg0", check=False)
# file
- path1 = os.path.join(os.getcwd(), "path1.txt")
- path2 = os.path.join(os.getcwd(), "path2.txt")
+ path1 = self.getBuildArtifact("path1.txt")
+ path2 = self.getBuildArtifact("path2.txt")
self.runCmd(
"settings set target.output-path %s" %
path1) # Set to known value
diff --git a/lldb/packages/Python/lldbsuite/test/settings/quoting/TestQuoting.py b/lldb/packages/Python/lldbsuite/test/settings/quoting/TestQuoting.py
index 54a96710b3d..0bf688a42ed 100644
--- a/lldb/packages/Python/lldbsuite/test/settings/quoting/TestQuoting.py
+++ b/lldb/packages/Python/lldbsuite/test/settings/quoting/TestQuoting.py
@@ -22,7 +22,7 @@ class SettingsCommandTestCase(TestBase):
@classmethod
def classCleanup(cls):
"""Cleanup the test byproducts."""
- cls.RemoveTempFile("stdout.txt")
+ cls.RemoveTempFile(self.getBuildArtifact("stdout.txt"))
@no_debug_info_test
def test_no_quote(self):
@@ -82,16 +82,22 @@ class SettingsCommandTestCase(TestBase):
exe = self.getBuildArtifact("a.out")
self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
- self.runCmd("process launch -- " + args_in)
+ local_outfile = self.getBuildArtifact("output.txt")
+ if lldb.remote_platform:
+ remote_outfile = "output.txt" # Relative to platform's PWD
+ else:
+ remote_outfile = local_outfile
+
+ self.runCmd("process launch -- %s %s" %(remote_outfile, args_in))
if lldb.remote_platform:
- src_file_spec = lldb.SBFileSpec('output.txt', False)
- dst_file_spec = lldb.SBFileSpec('output.txt', True)
+ src_file_spec = lldb.SBFileSpec(remote_outfile, False)
+ dst_file_spec = lldb.SBFileSpec(local_outfile, True)
lldb.remote_platform.Get(src_file_spec, dst_file_spec)
- with open('output.txt', 'r') as f:
+ with open(local_outfile, 'r') as f:
output = f.read()
- self.RemoveTempFile("output.txt")
+ self.RemoveTempFile(local_outfile)
self.assertEqual(output, args_out)
diff --git a/lldb/packages/Python/lldbsuite/test/settings/quoting/main.c b/lldb/packages/Python/lldbsuite/test/settings/quoting/main.c
index 5e3e34f84a6..2ebaa142bc5 100644
--- a/lldb/packages/Python/lldbsuite/test/settings/quoting/main.c
+++ b/lldb/packages/Python/lldbsuite/test/settings/quoting/main.c
@@ -8,11 +8,11 @@ main(int argc, char const *argv[])
{
int i;
- FILE *output = fopen ("output.txt", "w");
+ FILE *output = fopen (argv[1], "w");
if (output == NULL)
exit (1);
- for (i = 1; i < argc; ++i)
+ for (i = 2; i < argc; ++i)
fwrite(argv[i], strlen(argv[i])+1, 1, output);
fclose (output);
OpenPOWER on IntegriCloud