summaryrefslogtreecommitdiffstats
path: root/lldb/packages/Python/lldbsuite/test/lang/cpp/const_this
diff options
context:
space:
mode:
authorPavel Labath <pavel@labath.sk>2019-09-04 07:46:25 +0000
committerPavel Labath <pavel@labath.sk>2019-09-04 07:46:25 +0000
commit418a272f4ab4221c37a9272d48fd31d5ac1bddc1 (patch)
tree1bcc614932022201607d7f9e3f148f3c27cc5b14 /lldb/packages/Python/lldbsuite/test/lang/cpp/const_this
parent5bfe8b562ffb33fc09fa4a4c62f0146087d16ef6 (diff)
downloadbcm5719-llvm-418a272f4ab4221c37a9272d48fd31d5ac1bddc1.tar.gz
bcm5719-llvm-418a272f4ab4221c37a9272d48fd31d5ac1bddc1.zip
[dotest] Avoid the need for LEVEL= makefile boilerplate
Summary: Instead of each test case knowing its depth relative to the test root, we can just have dotest add the folder containing Makefile.rules to the include path. This was motivated by r370616, though I have been wanting to do this ever since we moved to building tests out-of-tree. The only manually modified files in this patch are lldbinline.py and plugins/builder_base.py. The rest of the patch has been produced by this shell command: find . \( -name Makefile -o -name '*.mk' \) -exec sed --in-place -e '/LEVEL *:\?=/d' -e '1,2{/^$/d}' -e 's,\$(LEVEL)/,,' {} + Reviewers: teemperor, aprantl, espindola, jfb Subscribers: emaste, javed.absar, arichardson, christof, arphaman, lldb-commits Differential Revision: https://reviews.llvm.org/D67083 llvm-svn: 370845
Diffstat (limited to 'lldb/packages/Python/lldbsuite/test/lang/cpp/const_this')
-rw-r--r--lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile b/lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile
index 52a92c0b61a..b5d2d900f90 100644
--- a/lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile
+++ b/lldb/packages/Python/lldbsuite/test/lang/cpp/const_this/Makefile
@@ -1,7 +1,6 @@
-LEVEL = ../../../make
CXX_SOURCES := main.cpp
CXXFLAGS += -std=c++11
-include $(LEVEL)/Makefile.rules
+include Makefile.rules
cleanup:
rm -f Makefile *.d
OpenPOWER on IntegriCloud