summaryrefslogtreecommitdiffstats
path: root/lldb/packages/Python/lldbsuite/test/android
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2015-10-28 17:43:26 +0000
committerZachary Turner <zturner@google.com>2015-10-28 17:43:26 +0000
commitc432c8f856e0bd84de980a9d9bb2d31b06fa95b1 (patch)
tree4efa528e074a6e2df782345e4cd97f5d85d038c4 /lldb/packages/Python/lldbsuite/test/android
parenta8a3bd210086b50242903ed95048fe5e53897878 (diff)
downloadbcm5719-llvm-c432c8f856e0bd84de980a9d9bb2d31b06fa95b1.tar.gz
bcm5719-llvm-c432c8f856e0bd84de980a9d9bb2d31b06fa95b1.zip
Move lldb/test to lldb/packages/Python/lldbsuite/test.
This is the conclusion of an effort to get LLDB's Python code structured into a bona-fide Python package. This has a number of benefits, but most notably the ability to more easily share Python code between different but related pieces of LLDB's Python infrastructure (for example, `scripts` can now share code with `test`). llvm-svn: 251532
Diffstat (limited to 'lldb/packages/Python/lldbsuite/test/android')
-rw-r--r--lldb/packages/Python/lldbsuite/test/android/platform/Makefile4
-rw-r--r--lldb/packages/Python/lldbsuite/test/android/platform/TestDefaultCacheLineSize.py38
-rw-r--r--lldb/packages/Python/lldbsuite/test/android/platform/main.cpp13
3 files changed, 55 insertions, 0 deletions
diff --git a/lldb/packages/Python/lldbsuite/test/android/platform/Makefile b/lldb/packages/Python/lldbsuite/test/android/platform/Makefile
new file mode 100644
index 00000000000..22e42c5a776
--- /dev/null
+++ b/lldb/packages/Python/lldbsuite/test/android/platform/Makefile
@@ -0,0 +1,4 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+include $(LEVEL)/Makefile.rules
diff --git a/lldb/packages/Python/lldbsuite/test/android/platform/TestDefaultCacheLineSize.py b/lldb/packages/Python/lldbsuite/test/android/platform/TestDefaultCacheLineSize.py
new file mode 100644
index 00000000000..221ff489f6d
--- /dev/null
+++ b/lldb/packages/Python/lldbsuite/test/android/platform/TestDefaultCacheLineSize.py
@@ -0,0 +1,38 @@
+"""
+Verify the default cache line size for android targets
+"""
+
+from __future__ import print_function
+
+import use_lldb_suite
+
+import os
+import lldb
+from lldbtest import *
+import lldbutil
+
+class DefaultCacheLineSizeTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @skipUnlessPlatform(['android'])
+ def test_cache_line_size(self):
+ self.build(dictionary=self.getBuildFlags())
+ exe = os.path.join(os.getcwd(), "a.out")
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target and target.IsValid(), "Target is valid")
+
+ breakpoint = target.BreakpointCreateByName("main")
+ self.assertTrue(breakpoint and breakpoint.IsValid(), "Breakpoint is valid")
+
+ # Run the program.
+ process = target.LaunchSimple(None, None, self.get_process_working_directory())
+ self.assertTrue(process and process.IsValid(), PROCESS_IS_VALID)
+ self.assertEqual(process.GetState(), lldb.eStateStopped, PROCESS_STOPPED)
+
+ # check the setting value
+ self.expect("settings show target.process.memory-cache-line-size", patterns=[" = 2048"])
+
+ # Run to completion.
+ process.Continue()
+ self.assertEqual(process.GetState(), lldb.eStateExited, PROCESS_EXITED)
diff --git a/lldb/packages/Python/lldbsuite/test/android/platform/main.cpp b/lldb/packages/Python/lldbsuite/test/android/platform/main.cpp
new file mode 100644
index 00000000000..3fb9edc4727
--- /dev/null
+++ b/lldb/packages/Python/lldbsuite/test/android/platform/main.cpp
@@ -0,0 +1,13 @@
+//===-- main.cpp ------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+int main ()
+{
+ return 0;
+}
OpenPOWER on IntegriCloud