summaryrefslogtreecommitdiffstats
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Gibbs <andyg1001@hotmail.co.uk>2013-06-20 06:47:36 +0000
committerAndy Gibbs <andyg1001@hotmail.co.uk>2013-06-20 06:47:36 +0000
commitac93aedc76f77bf70e9eb114d67ea2b0b4007650 (patch)
treee54010e2666b51cfccd42d7a13f6e2ecbe39f7af /lldb/CMakeLists.txt
parent89488966bd1179590919f6e162d5ffa6b1785bff (diff)
downloadbcm5719-llvm-ac93aedc76f77bf70e9eb114d67ea2b0b4007650.tar.gz
bcm5719-llvm-ac93aedc76f77bf70e9eb114d67ea2b0b4007650.zip
Revise r184335 so that warning suppression flag is only for clang 3.4 and higher
llvm-svn: 184399
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 3f0141b23c5..d0ccbe84ab9 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -118,9 +118,10 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
)
endif()
-if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang"
+ AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER "3.3")
add_lldb_definitions(
- -Wno-deprecated-register
+ -Wno-deprecated-register # Suppress "deprecated register keyword" warnings
)
endif()
OpenPOWER on IntegriCloud