summaryrefslogtreecommitdiffstats
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorTodd Fiala <todd.fiala@gmail.com>2015-10-04 01:28:51 +0000
committerTodd Fiala <todd.fiala@gmail.com>2015-10-04 01:28:51 +0000
commit65b9056f3dbba45ffd16d780b058a3d044115a59 (patch)
treed934e4bc8c904e9d2b9bec2d7ecbc6a34578a8c3 /lldb/CMakeLists.txt
parentb00e523d0051286b0408cc20bd861bbbaea83bcc (diff)
downloadbcm5719-llvm-65b9056f3dbba45ffd16d780b058a3d044115a59.tar.gz
bcm5719-llvm-65b9056f3dbba45ffd16d780b058a3d044115a59.zip
cmake: ensure readline python module target is added before finishing swig.
When the readline target exists (only for non-Android Linux currently), ensure that target is made a dependency of the finish_swig python-wrap-up steps. This ensures it is built when building the lldb target. Fixes: https://llvm.org/bugs/show_bug.cgi?id=25038 llvm-svn: 249256
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index 55fdf770001..e58a0c7cd41 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -24,6 +24,12 @@ if (NOT LLDB_DISABLE_PYTHON)
# We depend on liblldb being built before we can do this step.
add_dependencies(finish_swig liblldb argdumper)
+ # If we build the readline module, we depend on that happening
+ # first.
+ if (TARGET readline)
+ add_dependencies(finish_swig readline)
+ endif()
+
# Ensure we do the python post-build step when building lldb.
add_dependencies(lldb finish_swig)
OpenPOWER on IntegriCloud