summaryrefslogtreecommitdiffstats
path: root/lldb/CMakeLists.txt
diff options
context:
space:
mode:
authorVedant Kumar <vsk@apple.com>2016-08-19 18:41:50 +0000
committerVedant Kumar <vsk@apple.com>2016-08-19 18:41:50 +0000
commit181f924beb494c2ac778eff09559132c3c942d31 (patch)
tree80c38cb2a88b1c562c7b786c56573d0f82157995 /lldb/CMakeLists.txt
parent9b35e6d74618e108696199b6bb3821d941ab0ccc (diff)
downloadbcm5719-llvm-181f924beb494c2ac778eff09559132c3c942d31.tar.gz
bcm5719-llvm-181f924beb494c2ac778eff09559132c3c942d31.zip
[lldb][cmake] Remove libclang as an lldbBase dependency (NFCI)
It's pulling in all kinds of things it doesn't need (e.g, clang-tidy!). Eliminating this dependency removes 1056 dependencies from the 'CommandObjectFrame.cpp.o' target and 454 dependencies from the 'lldb' target. On my machine, this shaves 7 minutes off of a clean build of lldb. Thanks to Zachary Turner for pointing out some issues with an earlier version of this patch! Differential Revision: https://reviews.llvm.org/D22987 llvm-svn: 279296
Diffstat (limited to 'lldb/CMakeLists.txt')
-rw-r--r--lldb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lldb/CMakeLists.txt b/lldb/CMakeLists.txt
index e092e0bd4ab..a8c817e2c5b 100644
--- a/lldb/CMakeLists.txt
+++ b/lldb/CMakeLists.txt
@@ -1,5 +1,6 @@
cmake_minimum_required(VERSION 3.4.3)
+include(cmake/LLDBDependencies.cmake)
include(cmake/modules/LLDBStandalone.cmake)
include(cmake/modules/LLDBConfig.cmake)
include(cmake/modules/AddLLDB.cmake)
OpenPOWER on IntegriCloud