summaryrefslogtreecommitdiffstats
path: root/libcxxabi/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-01-14 03:47:49 +0000
committerEric Fiselier <eric@efcs.ca>2017-01-14 03:47:49 +0000
commitead6a4fc75c197795f9c162611c70f3f033f4c7f (patch)
tree09887780d5f7a032cf3c7aa237cfef0fffefcd2c /libcxxabi/CMakeLists.txt
parentb703fd32d651d5c2188bdd8f8738e6a93d03dfec (diff)
downloadbcm5719-llvm-ead6a4fc75c197795f9c162611c70f3f033f4c7f.tar.gz
bcm5719-llvm-ead6a4fc75c197795f9c162611c70f3f033f4c7f.zip
Don't dump llvm-config --cmakedir output if command fails.
This patch adjusts the out-of-tree CMake configuration so that the stderr output is ignored when an old llvm-config is found that doesn't support --cmakedir. llvm-svn: 291993
Diffstat (limited to 'libcxxabi/CMakeLists.txt')
-rw-r--r--libcxxabi/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
index adee47fa490..ac653925bf6 100644
--- a/libcxxabi/CMakeLists.txt
+++ b/libcxxabi/CMakeLists.txt
@@ -55,7 +55,8 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
execute_process(
COMMAND ${LLVM_CONFIG_PATH} --cmakedir
RESULT_VARIABLE HAD_ERROR
- OUTPUT_VARIABLE CONFIG_OUTPUT)
+ OUTPUT_VARIABLE CONFIG_OUTPUT
+ ERROR_QUIET)
if(NOT HAD_ERROR)
string(STRIP "${CONFIG_OUTPUT}" LLVM_CMAKE_PATH)
else()
OpenPOWER on IntegriCloud