summaryrefslogtreecommitdiffstats
path: root/libcxxabi/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2017-07-31 09:35:08 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2017-07-31 09:35:08 +0000
commit83105a4ae1f6c3ecc42a8f4db61b785f1a5488f2 (patch)
tree6fce212e03b19cc1bc8d40ec5200e1e1c37b911b /libcxxabi/CMakeLists.txt
parenta2e7ca99e046920b6fb46096dd10a0ab89ae0235 (diff)
downloadbcm5719-llvm-83105a4ae1f6c3ecc42a8f4db61b785f1a5488f2.tar.gz
bcm5719-llvm-83105a4ae1f6c3ecc42a8f4db61b785f1a5488f2.zip
libcxxabi: Suppress LLVM_ENABLE_MODULES
Differential Revision: https://reviews.llvm.org/D35542 llvm-svn: 309551
Diffstat (limited to 'libcxxabi/CMakeLists.txt')
-rw-r--r--libcxxabi/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
index 94df9f15637..456250e6d89 100644
--- a/libcxxabi/CMakeLists.txt
+++ b/libcxxabi/CMakeLists.txt
@@ -345,6 +345,12 @@ if (LIBCXXABI_HAS_EXTERNAL_THREAD_API)
endif()
endif()
+if (LLVM_ENABLE_MODULES)
+ # Ignore that the rest of the modules flags are now unused.
+ add_compile_flags_if_supported(-Wno-unused-command-line-argument)
+ add_compile_flags(-fno-modules)
+endif()
+
set(LIBCXXABI_HAS_UNDEFINED_SYMBOLS OFF)
if ((NOT LIBCXXABI_ENABLE_NEW_DELETE_DEFINITIONS)
OR (LIBCXXABI_BUILD_EXTERNAL_THREAD_LIBRARY AND LIBCXXABI_ENABLE_SHARED)
OpenPOWER on IntegriCloud