summaryrefslogtreecommitdiffstats
path: root/libcxxabi/CMakeLists.txt
diff options
context:
space:
mode:
authorAsiri Rathnayake <asiri.rathnayake@arm.com>2017-04-04 14:03:54 +0000
committerAsiri Rathnayake <asiri.rathnayake@arm.com>2017-04-04 14:03:54 +0000
commit4cc78d7008ab6b8a7b09d01881e1d24aa8958c6d (patch)
tree8974dab74cb4e1b0a1891d30014988e45e1f72ff /libcxxabi/CMakeLists.txt
parentdbdcfa127f333127cb248d1819780f7fdbc5cf5a (diff)
downloadbcm5719-llvm-4cc78d7008ab6b8a7b09d01881e1d24aa8958c6d.tar.gz
bcm5719-llvm-4cc78d7008ab6b8a7b09d01881e1d24aa8958c6d.zip
Fix exception address alignment test for EHABI
This test fails on ARM bare-metal targets because it assumes the Itanium ABI, whereas EHABI requires the exception address to be 8-byte aligned. I was a bit puzzled at first because this should've failed on the public arm-linux builder too. I think the reason it passes there is because we don't include libunwind headers in the include path when running the libcxxabi tests, so the system unwind.h gets picked up. Reviewers: rengolin, EricWF Differential revision: https://reviews.llvm.org/D31178 llvm-svn: 299435
Diffstat (limited to 'libcxxabi/CMakeLists.txt')
-rw-r--r--libcxxabi/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
index be76724a66d..162db8e1699 100644
--- a/libcxxabi/CMakeLists.txt
+++ b/libcxxabi/CMakeLists.txt
@@ -502,9 +502,14 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
set(LIBCXXABI_LIBUNWIND_SOURCES "")
endif()
- if (NOT LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL-NOTFOUND")
+ if (LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL-NOTFOUND")
+ set(LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL "")
+ endif()
+
+ if (NOT LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "")
include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL}")
endif()
+
if (NOT LIBCXXABI_LIBUNWIND_SOURCES STREQUAL "")
include_directories("${LIBCXXABI_LIBUNWIND_SOURCES}")
endif()
OpenPOWER on IntegriCloud