summaryrefslogtreecommitdiffstats
path: root/libcxx/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorHoward Hinnant <hhinnant@apple.com>2011-09-22 19:10:18 +0000
committerHoward Hinnant <hhinnant@apple.com>2011-09-22 19:10:18 +0000
commit3c78ca07bcfad4053c713cb96538594480fde3af (patch)
tree0bba5686be76fd18a86605bba7132575e5faea13 /libcxx/lib/CMakeLists.txt
parentf9b785f1851ae7ee0d39b597637daaf966d356dc (diff)
downloadbcm5719-llvm-3c78ca07bcfad4053c713cb96538594480fde3af.tar.gz
bcm5719-llvm-3c78ca07bcfad4053c713cb96538594480fde3af.zip
Partial Windows port by Ruben Van Boxem
llvm-svn: 140328
Diffstat (limited to 'libcxx/lib/CMakeLists.txt')
-rw-r--r--libcxx/lib/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/libcxx/lib/CMakeLists.txt b/libcxx/lib/CMakeLists.txt
index d8065cdcfe9..f4af4e06972 100644
--- a/libcxx/lib/CMakeLists.txt
+++ b/libcxx/lib/CMakeLists.txt
@@ -1,9 +1,17 @@
# Get sources
-file(GLOB_RECURSE sources ../src/*.cpp)
+file(GLOB sources ../src/*.cpp)
+if(WIN32)
+ file(GLOB win32_sources ../src/support/win32/*.cpp)
+ list(APPEND sources ${win32_sources})
+endif()
# Add all the headers to the project for IDEs.
if (MSVC_IDE OR XCODE)
file(GLOB_RECURSE headers ../include/*)
+ if(WIN32)
+ file( GLOB win32_headers ../include/support/win32/*.h)
+ list(APPEND headers ${win32_headers})
+ endif()
# Force them all into the headers dir on MSVC, otherwise they end up at
# project scope because they don't have extensions.
if (MSVC_IDE)
OpenPOWER on IntegriCloud